aboutsummaryrefslogtreecommitdiffstats
path: root/art/Makefile.am
diff options
context:
space:
mode:
authorMichael Monreal <michael.monreal@gmail.com>2007-10-12 17:49:02 +0800
committerMilan Crha <mcrha@src.gnome.org>2007-10-12 17:49:02 +0800
commit953e66428af9639028b3729b448d1fa01c340d09 (patch)
treed413a2f65852df6fe5fe6eee913378dab774ed23 /art/Makefile.am
parentbe9273d7bab214c49479b4cc96f0a2ffe26ce019 (diff)
downloadgsoc2013-evolution-953e66428af9639028b3729b448d1fa01c340d09.tar
gsoc2013-evolution-953e66428af9639028b3729b448d1fa01c340d09.tar.gz
gsoc2013-evolution-953e66428af9639028b3729b448d1fa01c340d09.tar.bz2
gsoc2013-evolution-953e66428af9639028b3729b448d1fa01c340d09.tar.lz
gsoc2013-evolution-953e66428af9639028b3729b448d1fa01c340d09.tar.xz
gsoc2013-evolution-953e66428af9639028b3729b448d1fa01c340d09.tar.zst
gsoc2013-evolution-953e66428af9639028b3729b448d1fa01c340d09.zip
** Migration of theme icons to data/icons/ (bug #479257)
2007-10-12 Michael Monreal <michael.monreal@gmail.com> ** Migration of theme icons to data/icons/ (bug #479257) * art/Makefile.am: Remove references to art/$size. * configure.in: Include new data/icons/ directory. * file e-util/e-icon-factory.c: Append a private icon directory to the search path. New inbox/outbox/sent icons. * mail/em-folder-tree.c, mail/mail-send-recv.c: Change icon references. New view-calendar icons. * calendar/gui/calendar-commands.c: Change icon references. svn path=/trunk/; revision=34383
Diffstat (limited to 'art/Makefile.am')
-rw-r--r--art/Makefile.am43
1 files changed, 0 insertions, 43 deletions
diff --git a/art/Makefile.am b/art/Makefile.am
index 9f6a989f55..bded28a1a5 100644
--- a/art/Makefile.am
+++ b/art/Makefile.am
@@ -1,29 +1,3 @@
-icon16dir = $(datadir)/icons/hicolor/16x16/apps
-icon16_DATA = 16x16/evolution.png
-
-icon22dir = $(datadir)/icons/hicolor/22x22/apps
-icon22_DATA = 22x22/evolution.png
-
-icon24dir = $(datadir)/icons/hicolor/24x24/apps
-icon24_DATA = 24x24/evolution.png
-
-icon32dir = $(datadir)/icons/hicolor/32x32/apps
-icon32_DATA = 32x32/evolution.png
-
-icon48dir = $(datadir)/icons/hicolor/48x48/apps
-icon48_DATA = \
- 48x48/preferences-autocompletion.png \
- 48x48/preferences-calendar-and-tasks.png \
- 48x48/preferences-certificates.png \
- 48x48/preferences-composer.png \
- 48x48/preferences-mail-accounts.png \
- 48x48/preferences-mail.png
-
-svgicondir = $(datadir)/icons/hicolor/scalable/apps
-svgicon_DATA = scalable/evolution.svg
-
-gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
-
images_DATA = \
evolution-contacts-mini.png \
offline.png \
@@ -33,17 +7,6 @@ images_DATA = \
plus.png \
minus.png
-install-data-hook: update-icon-cache
-uninstall-hook: update-icon-cache
-update-icon-cache:
- @-if test -z "$(DESTDIR)"; then \
- echo "Updating Gtk icon cache."; \
- $(gtk_update_icon_cache); \
- else \
- echo "*** Icon cache not updated. After (un)install, run this:"; \
- echo "*** $(gtk_update_icon_cache)"; \
- fi
-
EXTRA_DIST = \
ChangeLog \
ChangeLog.pre-1-4 \
@@ -52,10 +15,4 @@ EXTRA_DIST = \
broken-image-24.xpm \
empty.xpm \
jump.xpm \
- $(icon16_DATA) \
- $(icon22_DATA) \
- $(icon24_DATA) \
- $(icon32_DATA) \
- $(icon48_DATA) \
- $(svgicon_DATA) \
$(images_DATA)