aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/tools/Makefile.am
diff options
context:
space:
mode:
authorGilbert Fang <gilbert.fang@sun.com>2003-04-08 00:21:03 +0800
committerChris Toshok <toshok@src.gnome.org>2003-04-08 00:21:03 +0800
commit52e08661fd82890ce38cfb52854cafdc66dbe5d9 (patch)
tree5a878ac562ccb2c7216126694882c17e8b820233 /addressbook/tools/Makefile.am
parent2cd3d433867f8e003e16c836289cdc7fec072fe1 (diff)
downloadgsoc2013-evolution-52e08661fd82890ce38cfb52854cafdc66dbe5d9.tar
gsoc2013-evolution-52e08661fd82890ce38cfb52854cafdc66dbe5d9.tar.gz
gsoc2013-evolution-52e08661fd82890ce38cfb52854cafdc66dbe5d9.tar.bz2
gsoc2013-evolution-52e08661fd82890ce38cfb52854cafdc66dbe5d9.tar.lz
gsoc2013-evolution-52e08661fd82890ce38cfb52854cafdc66dbe5d9.tar.xz
gsoc2013-evolution-52e08661fd82890ce38cfb52854cafdc66dbe5d9.tar.zst
gsoc2013-evolution-52e08661fd82890ce38cfb52854cafdc66dbe5d9.zip
[ fixes bug #23036 ] : new and improved export utility.
2003-04-07 Gilbert Fang <gilbert.fang@sun.com> [ fixes bug #23036 ] * tools/evolution-addressbook-export.c, tools/evolution-addressbook-export-list-cards.c, tools/evolution-addressbook-export-list-folders.c: : new and improved export utility. svn path=/trunk/; revision=20709
Diffstat (limited to 'addressbook/tools/Makefile.am')
-rw-r--r--addressbook/tools/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/addressbook/tools/Makefile.am b/addressbook/tools/Makefile.am
new file mode 100644
index 0000000000..79a1c746ad
--- /dev/null
+++ b/addressbook/tools/Makefile.am
@@ -0,0 +1,33 @@
+bin_PROGRAMS = \
+ evolution-addressbook-export
+
+INCLUDES = \
+ -DG_LOG_DOMAIN=\"evolution-addressbook-tools\" \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DPREFIX=\""$(prefix)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -I$(top_srcdir)/addressbook \
+ -I$(top_srcdir)/addressbook/backend \
+ -I$(top_builddir)/addressbook/backend \
+ -DG_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED \
+ $(GNOME_FULL_CFLAGS)
+
+evolution_addressbook_export_SOURCES = \
+ evolution-addressbook-export.c \
+ evolution-addressbook-export-list-cards.c \
+ evolution-addressbook-export-list-folders.c \
+ evolution-addressbook-export.h
+
+evolution_addressbook_export_LDADD = \
+ $(GNOME_FULL_LIBS) \
+ $(top_builddir)/addressbook/backend/ebook/libebook.la \
+ $(top_builddir)/widgets/menus/libmenus.la \
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/libversit/libversit.la \
+ $(top_builddir)/e-util/ename/libename.la \
+ $(top_builddir)/e-util/libeutil.la
+