aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/tools/Makefile.am
diff options
context:
space:
mode:
authorMilan Crha <mcrha@redhat.com>2014-03-25 19:04:58 +0800
committerMilan Crha <mcrha@redhat.com>2014-03-25 19:04:58 +0800
commit8692b1cb72654888f0dab31843bdf05d3ac2a888 (patch)
tree3e172e8085830cf0770cf0a7ab04bd714753d3a9 /addressbook/tools/Makefile.am
parent399b1a6fc593a9c5e692923120346e0386f578e5 (diff)
downloadgsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.gz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.bz2
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.lz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.xz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.zst
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.zip
Add an --enable-code-coverage configure option to enable gcov support
When enabled, this will compile all libraries/binaries with the necessary gcc and ld flags to enable code coverage support using gcov.
Diffstat (limited to 'addressbook/tools/Makefile.am')
-rw-r--r--addressbook/tools/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/addressbook/tools/Makefile.am b/addressbook/tools/Makefile.am
index 4d2e6d4746..f92b20589c 100644
--- a/addressbook/tools/Makefile.am
+++ b/addressbook/tools/Makefile.am
@@ -15,7 +15,8 @@ evolution_addressbook_export_CPPFLAGS = \
-DLIBDIR=\""$(libdir)"\" \
-I$(top_srcdir)/addressbook \
-I$(top_builddir)/addressbook \
- $(EVOLUTION_DATA_SERVER_CFLAGS)
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(CODE_COVERAGE_CFLAGS)
evolution_addressbook_export_SOURCES = \
evolution-addressbook-export.c \
@@ -26,8 +27,10 @@ evolution_addressbook_export_SOURCES = \
evolution_addressbook_export_LDADD = \
$(EVOLUTION_DATA_SERVER_LIBS)
+evolution_addressbook_export_LDFLAGS = $(CODE_COVERAGE_LDFLAGS)
+
if OS_WIN32
-evolution_addressbook_export_LDFLAGS = -mwindows
+evolution_addressbook_export_LDFLAGS += -mwindows
endif
EXTRA_DIST = $(privlibexec_SCRIPTS)