aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/printing/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2011-10-05 09:32:41 +0800
committerMatthew Barnes <mbarnes@redhat.com>2011-10-05 10:27:14 +0800
commit1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba (patch)
tree8b3d99bcac99c3a3edbb2939ea0226c187a39eb4 /addressbook/printing/Makefile.am
parent273b10a5baebd97bea4aeb1dae158f93ce93eb72 (diff)
downloadgsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar.gz
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar.bz2
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar.lz
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar.xz
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar.zst
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.zip
Simplify library dependency flags.
We have a confusing array of nearly-identical CFLAGS/LIBS definitions in configure.ac. Time to simplify. Instead let's just have one definition that includes all the libraries provided by Evolution-Data-Server (incl. Camel). That, in combination with GNOME_PLATFORM, gives us most of what we need for compliation and linking, and we can sprinkle definitions for additional library dependencies in Makefile.am's as needed.
Diffstat (limited to 'addressbook/printing/Makefile.am')
-rw-r--r--addressbook/printing/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/addressbook/printing/Makefile.am b/addressbook/printing/Makefile.am
index c315b49d0a..edf3cc9795 100644
--- a/addressbook/printing/Makefile.am
+++ b/addressbook/printing/Makefile.am
@@ -11,8 +11,8 @@ libecontactprint_la_CPPFLAGS = \
-I$(top_srcdir) \
-DEVOLUTION_UIDIR=\""$(uidir)"\" \
-DEVOLUTION_ECPSDIR=\""$(ecpsdir)"\" \
- $(GNOME_PLATFORM_CFLAGS) \
- $(EVOLUTION_ADDRESSBOOK_CFLAGS)
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS)
noinst_LTLIBRARIES = libecontactprint.la
@@ -22,8 +22,9 @@ libecontactprint_la_SOURCES = \
e-contact-print.h
libecontactprint_la_LIBADD = \
- $(top_builddir)/e-util/libeutil.la \
$(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
$(GNOME_PLATFORM_LIBS)
noinst_PROGRAMS = contact-print-test
@@ -34,17 +35,17 @@ contact_print_test_CPPFLAGS = \
-I$(top_srcdir)/addressbook \
-I$(top_srcdir) \
-DEVOLUTION_ECPSDIR=\""$(ecpsdir)"\" \
- $(GNOME_PLATFORM_CFLAGS) \
- $(EVOLUTION_ADDRESSBOOK_CFLAGS)
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS)
contact_print_test_SOURCES = test-print.c
contact_print_test_LDADD = \
libecontactprint.la \
$(top_builddir)/addressbook/util/libeabutil.la \
- $(top_builddir)/e-util/libeutil.la \
$(top_builddir)/shell/libeshell.la \
- $(EVOLUTION_ADDRESSBOOK_LIBS) \
+ $(top_builddir)/e-util/libeutil.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
$(GNOME_PLATFORM_LIBS)
EXTRA_DIST = \