aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/printing/Makefile.am
diff options
context:
space:
mode:
authorChristopher James Lahey <clahey@helixcode.com>2000-02-02 09:16:29 +0800
committerChris Lahey <clahey@src.gnome.org>2000-02-02 09:16:29 +0800
commitc499722cef56ddd2ebfd8d2ff2c6c21c8918a9b0 (patch)
treed89f7b3b24a3bc8094f0d883226ebd4b0901423e /addressbook/printing/Makefile.am
parent1da8f9c265082e10fb9694a6bf92a0bae2b1312b (diff)
downloadgsoc2013-evolution-c499722cef56ddd2ebfd8d2ff2c6c21c8918a9b0.tar
gsoc2013-evolution-c499722cef56ddd2ebfd8d2ff2c6c21c8918a9b0.tar.gz
gsoc2013-evolution-c499722cef56ddd2ebfd8d2ff2c6c21c8918a9b0.tar.bz2
gsoc2013-evolution-c499722cef56ddd2ebfd8d2ff2c6c21c8918a9b0.tar.lz
gsoc2013-evolution-c499722cef56ddd2ebfd8d2ff2c6c21c8918a9b0.tar.xz
gsoc2013-evolution-c499722cef56ddd2ebfd8d2ff2c6c21c8918a9b0.tar.zst
gsoc2013-evolution-c499722cef56ddd2ebfd8d2ff2c6c21c8918a9b0.zip
Files to load the contact print style editor from the glade file. Doesn't
2000-01-28 Christopher James Lahey <clahey@helixcode.com> * addressbook/printing/e-contact-print-style-editor.h, addressbook/printing/e-contact-print-style-editor.c, addressbook/printing/test-contact-print-style-editor.c: Files to load the contact print style editor from the glade file. Doesn't really do anything yet. * addressbook/printing/Makefile.am: Added style editor stuff. * addressbook/printing/e-contact-print.glade: Changed a bit. Fixed an out of place widget. * addressbook/printing/.cvsignore: Added contact-print-style-editor-test. * addressbook/printing/smallbook.ecps: Fixed up the values to match the new types. * addressbook/printing/medbook.ecps, addressbook/printing/phonelist.ecps: Added two new printing styles. * addressbook/printing/e-contact-print.h: Fixed an incorrect comment. * addressbook/printing/e-contact-print.c: Added columns and letter tabs. Tweaked spacing all over the place. Fixed card height function so that column wrapping is always done correctly. Added pulling of style information from a file. Added line wrapping within each text field. * addressbook/printing/e-contact-print-types.h: Added a type field for different types of print styles. svn path=/trunk/; revision=1659
Diffstat (limited to 'addressbook/printing/Makefile.am')
-rw-r--r--addressbook/printing/Makefile.am17
1 files changed, 14 insertions, 3 deletions
diff --git a/addressbook/printing/Makefile.am b/addressbook/printing/Makefile.am
index 4fabafafd3..7095171859 100644
--- a/addressbook/printing/Makefile.am
+++ b/addressbook/printing/Makefile.am
@@ -13,10 +13,13 @@ noinst_LIBRARIES = \
libecontactprint_a_SOURCES = \
e-contact-print.c \
e-contact-print.h \
+ e-contact-print-style-editor.c \
+ e-contact-print-style-editor.h \
e-contact-print-types.h
noinst_PROGRAMS = \
- contact-print-test
+ contact-print-test \
+ contact-print-style-editor-test
contact_print_test_SOURCES = \
test-print.c
@@ -26,8 +29,16 @@ contact_print_test_LDADD = \
libecontactprint.a \
$(GNOME_PRINT_LIBS)
+contact_print_style_editor_test_SOURCES = \
+ test-contact-print-style-editor.c
+
+contact_print_style_editor_test_LDADD = \
+ $(EXTRA_GNOME_LIBS) \
+ libecontactprint.a \
+ $(GNOME_PRINT_LIBS)
+
gladedir = $(datadir)/evolution/glade
-#glade_DATA = \
-# e-contact-print.glade
+glade_DATA = \
+ e-contact-print.glade