aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/printing/Makefile.am
diff options
context:
space:
mode:
authorChristopher James Lahey <clahey@helixcode.com>2000-01-26 08:04:14 +0800
committerChris Lahey <clahey@src.gnome.org>2000-01-26 08:04:14 +0800
commit20efd536d04574d105bc8814af4a79cb4e9031e6 (patch)
tree2639675b33edac8e1f728557957f3e377f4ff338 /addressbook/printing/Makefile.am
parent1183808afc92edf659d05876bcda209a78e5c411 (diff)
downloadgsoc2013-evolution-20efd536d04574d105bc8814af4a79cb4e9031e6.tar
gsoc2013-evolution-20efd536d04574d105bc8814af4a79cb4e9031e6.tar.gz
gsoc2013-evolution-20efd536d04574d105bc8814af4a79cb4e9031e6.tar.bz2
gsoc2013-evolution-20efd536d04574d105bc8814af4a79cb4e9031e6.tar.lz
gsoc2013-evolution-20efd536d04574d105bc8814af4a79cb4e9031e6.tar.xz
gsoc2013-evolution-20efd536d04574d105bc8814af4a79cb4e9031e6.tar.zst
gsoc2013-evolution-20efd536d04574d105bc8814af4a79cb4e9031e6.zip
Example contact printing style. Not used yet.
2000-01-25 Christopher James Lahey <clahey@helixcode.com> * addressbook/printing/smallbook.ecps: Example contact printing style. Not used yet. * addressbook/printing/e-contact-print.glade: A glade file for editing contact printing styles. Not used yet. * addressbook/printing/test-print.c: Test file for printing. * addressbook/printing/e-contact-print.c, addressbook/printing/e-contact-print.h, addressbook/printing/e-contact-print-types.h, addressbook/printing/Makefile.am, addressbook/printing/.cvsignore: New files for contact printing support. * addressbook/Makefile.am (SUBDIRS): Add printing. * configure.in: Check for gnome-print. Build the addressbook/printing Makefile. svn path=/trunk/; revision=1634
Diffstat (limited to 'addressbook/printing/Makefile.am')
-rw-r--r--addressbook/printing/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/addressbook/printing/Makefile.am b/addressbook/printing/Makefile.am
new file mode 100644
index 0000000000..4fabafafd3
--- /dev/null
+++ b/addressbook/printing/Makefile.am
@@ -0,0 +1,33 @@
+
+CPPFLAGS = \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ $(GNOME_PRINT_CFLAGS)
+
+INCLUDES = \
+ $(GNOME_INCLUDEDIR)
+
+noinst_LIBRARIES = \
+ libecontactprint.a
+
+libecontactprint_a_SOURCES = \
+ e-contact-print.c \
+ e-contact-print.h \
+ e-contact-print-types.h
+
+noinst_PROGRAMS = \
+ contact-print-test
+
+contact_print_test_SOURCES = \
+ test-print.c
+
+contact_print_test_LDADD = \
+ $(EXTRA_GNOME_LIBS) \
+ libecontactprint.a \
+ $(GNOME_PRINT_LIBS)
+
+gladedir = $(datadir)/evolution/glade
+
+#glade_DATA = \
+# e-contact-print.glade
+