aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/printing/Makefile.am
diff options
context:
space:
mode:
authorChristopher James Lahey <clahey@helixcode.com>2000-05-24 07:42:40 +0800
committerChris Lahey <clahey@src.gnome.org>2000-05-24 07:42:40 +0800
commitb6485f13c4dcc1c5dc9b6a7c8c3d8931d06da90e (patch)
tree13f012bb3c0a3cc27b754b8eb019e0d505b4e7fc /addressbook/printing/Makefile.am
parent735213b4cd031c53106ba2cf70c2d0ecd85cfdd0 (diff)
downloadgsoc2013-evolution-b6485f13c4dcc1c5dc9b6a7c8c3d8931d06da90e.tar
gsoc2013-evolution-b6485f13c4dcc1c5dc9b6a7c8c3d8931d06da90e.tar.gz
gsoc2013-evolution-b6485f13c4dcc1c5dc9b6a7c8c3d8931d06da90e.tar.bz2
gsoc2013-evolution-b6485f13c4dcc1c5dc9b6a7c8c3d8931d06da90e.tar.lz
gsoc2013-evolution-b6485f13c4dcc1c5dc9b6a7c8c3d8931d06da90e.tar.xz
gsoc2013-evolution-b6485f13c4dcc1c5dc9b6a7c8c3d8931d06da90e.tar.zst
gsoc2013-evolution-b6485f13c4dcc1c5dc9b6a7c8c3d8931d06da90e.zip
Switched printing and gui.
2000-05-23 Christopher James Lahey <clahey@helixcode.com> * Makefile.am: Switched printing and gui. * backend/ebook/e-book-view-listener.h, backend/ebook/e-book-view.h, backend/ebook/e-book.h, backend/ebook/e-card-cursor.h, backend/ebook/e-card-list.h, backend/ebook/e-card-simple.h, backend/ebook/e-card.h: Fixed the #defines to work elsewhere in evolution. * gui/component/Makefile.am: Added linking to libecontactprint. * gui/component/addressbook.c: Added a menu item to print the current query. * printing/Makefile.am: Add linking to libebook and requirements. Add installation of ecps files. * printing/e-contact-print.c, printing/e-contact-print.h: Changed this to use real data from an EBook. * printing/test-print.c: Made this pass NULL, NULL to e_contact_print_dialog_new so that it will compile. svn path=/trunk/; revision=3188
Diffstat (limited to 'addressbook/printing/Makefile.am')
-rw-r--r--addressbook/printing/Makefile.am34
1 files changed, 26 insertions, 8 deletions
diff --git a/addressbook/printing/Makefile.am b/addressbook/printing/Makefile.am
index 0aa9dbef9d..d0268d7dbc 100644
--- a/addressbook/printing/Makefile.am
+++ b/addressbook/printing/Makefile.am
@@ -1,12 +1,26 @@
+ecpsdir = $(datadir)/evolution/ecps
+
+ecps_DATA = \
+ smallbook.ecps \
+ medbook.ecps \
+ phonelist.ecps
+
+gladedir = $(datadir)/evolution/glade
+
+glade_DATA = \
+ e-contact-print.glade
CPPFLAGS = \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ECPSDIR=\""$(ecpsdir)"\" \
-DDATADIR=\""$(datadir)"\" \
$(GNOME_PRINT_CFLAGS)
INCLUDES = \
$(GNOME_INCLUDEDIR) \
- -DG_LOG_DOMAIN=\"addressbook-printing\"
+ -DG_LOG_DOMAIN=\"addressbook-printing\" \
+ -I$(top_srcdir)/addressbook \
+ -I$(top_srcdir)
noinst_LIBRARIES = \
libecontactprint.a
@@ -27,6 +41,11 @@ contact_print_test_SOURCES = \
contact_print_test_LDADD = \
$(EXTRA_GNOME_LIBS) \
+ -lbonobo \
+ $(top_builddir)/addressbook/backend/ebook/libebook.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/libversit/libversit.la \
+ $(top_builddir)/addressbook/ename/libename.la \
libecontactprint.a \
$(GNOME_PRINT_LIBS)
@@ -35,13 +54,12 @@ contact_print_style_editor_test_SOURCES = \
contact_print_style_editor_test_LDADD = \
$(EXTRA_GNOME_LIBS) \
+ -lbonobo \
+ $(top_builddir)/addressbook/backend/ebook/libebook.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/libversit/libversit.la \
+ $(top_builddir)/addressbook/ename/libename.la \
libecontactprint.a \
$(GNOME_PRINT_LIBS)
-gladedir = $(datadir)/evolution/glade
-
-glade_DATA = \
- e-contact-print.glade
-
-EXTRA_DIST = $(glade_DATA)
-
+EXTRA_DIST = $(glade_DATA) $(ecps_DATA)