aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/widgets/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2001-06-25 09:09:43 +0800
committerChris Toshok <toshok@src.gnome.org>2001-06-25 09:09:43 +0800
commit8cb68557aebb62334f68beeea60cf3bbf5930f9e (patch)
treebc27d2cd32645cddfd8631f6d6cc602ab29eea4e /addressbook/gui/widgets/Makefile.am
parentdcf2e1a4acef258ff7473425cbd8d119294e41c0 (diff)
downloadgsoc2013-evolution-8cb68557aebb62334f68beeea60cf3bbf5930f9e.tar
gsoc2013-evolution-8cb68557aebb62334f68beeea60cf3bbf5930f9e.tar.gz
gsoc2013-evolution-8cb68557aebb62334f68beeea60cf3bbf5930f9e.tar.bz2
gsoc2013-evolution-8cb68557aebb62334f68beeea60cf3bbf5930f9e.tar.lz
gsoc2013-evolution-8cb68557aebb62334f68beeea60cf3bbf5930f9e.tar.xz
gsoc2013-evolution-8cb68557aebb62334f68beeea60cf3bbf5930f9e.tar.zst
gsoc2013-evolution-8cb68557aebb62334f68beeea60cf3bbf5930f9e.zip
correct path to libecontacteditor.a. (minicard_widget_test_LDADD): same.
2001-06-24 Chris Toshok <toshok@ximian.com> * gui/widgets/Makefile.am (minicard_test_LDADD): correct path to libecontacteditor.a. (minicard_widget_test_LDADD): same. (INCLUDES): same, for the includes. * gui/widgets/e-minicard.h: correct e-contact-editor.h path. * gui/widgets/e-addressbook-util.h: correct path to e-contact-editor.h, and add e-contact-list-editor.h. Add prototype for e_addressbook_show_contact_list_editor. * gui/widgets/e-addressbook-util.c: remove #include "e-contact-editor.h" (our header includes it.) (added_cb): rename card_added_cb to this, and make it so it can be reused in both the list and card cases. remove the g_print too. (modified_cb): same for modified case. (deleted_cb): same for deleted case. (editor_closed_cb): change first arg to GtkObject* so we can reuse this for both list and card. (e_addressbook_show_contact_editor): use added_cb, modified_cb, deleted_cb, and pass FALSE as user_data. (e_addressbook_show_contact_list_editor): new function, same as above but creating a contact-list-editor, and pass TRUE as user_data. * gui/component/e-address-popup.c: correct path to contact-editor. * gui/component/e-address-widget.c: same. * gui/component/select-names/e-select-names-popup.c: same. * gui/component/select-names/e-select-names-text-model.c: same. * gui/component/addressbook.c (new_contact_list_cb): new function. (update_command_state): update ContactNewList command. (verbs): remove ViewAll from the toolbar from the verb list. Add ContactNewList. (pixmaps): same for pixmaps. * gui/component/Makefile.am (evolution_addressbook_LDADD): new path for contact-editor. (INCLUDES): same. * gui/contact-list-editor/e-contact-list-model.h: * gui/contact-list-editor/e-contact-list-model.c: * gui/contact-list-editor/e-contact-list-editor.h: * gui/contact-list-editor/e-contact-list-editor.c: * gui/contact-list-editor/Makefile.am: Initial contact-list editor commit. * gui/Makefile.am (SUBDIRS): add contact-editor. * Makefile.am: (SUBDIRS): remove contact-editor. svn path=/trunk/; revision=10463
Diffstat (limited to 'addressbook/gui/widgets/Makefile.am')
-rw-r--r--addressbook/gui/widgets/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/addressbook/gui/widgets/Makefile.am b/addressbook/gui/widgets/Makefile.am
index a375965a66..9619363732 100644
--- a/addressbook/gui/widgets/Makefile.am
+++ b/addressbook/gui/widgets/Makefile.am
@@ -4,7 +4,7 @@ INCLUDES = \
-DEVOLUTION_DATADIR=\""$(datadir)"\" \
-I$(top_srcdir) \
-I$(top_srcdir)/addressbook/backend/ebook \
- -I$(top_srcdir)/addressbook/contact-editor \
+ -I$(top_srcdir)/addressbook/gui/contact-editor \
-I$(top_srcdir)/addressbook/gui/merging \
-I$(top_srcdir)/widgets/misc \
$(BONOBO_GNOME_CFLAGS) \
@@ -66,7 +66,8 @@ minicard_test_LDADD = \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/libversit/libversit.la \
$(top_builddir)/e-util/ename/libename.la \
- $(top_builddir)/addressbook/contact-editor/libecontacteditor.a \
+ $(top_builddir)/addressbook/gui/contact-editor/libecontacteditor.a \
+ $(top_builddir)/addressbook/gui/contact-list-editor/libecontactlisteditor.a \
$(top_builddir)/addressbook/printing/libecontactprint.a \
$(top_builddir)/addressbook/gui/merging/libecardmerging.a \
$(top_builddir)/widgets/misc/libemiscwidgets.a \
@@ -118,7 +119,8 @@ minicard_widget_test_LDADD = \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/libversit/libversit.la \
$(top_builddir)/e-util/ename/libename.la \
- $(top_builddir)/addressbook/contact-editor/libecontacteditor.a \
+ $(top_builddir)/addressbook/gui/contact-editor/libecontacteditor.a \
+ $(top_builddir)/addressbook/gui/contact-list-editor/libecontactlisteditor.a \
$(top_builddir)/addressbook/printing/libecontactprint.a \
$(top_builddir)/widgets/misc/libemiscwidgets.a \
$(top_builddir)/e-util/libeutil.la \