aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/widgets/Makefile.am
diff options
context:
space:
mode:
authorChristopher James Lahey <clahey@helixcode.com>2000-09-18 00:55:16 +0800
committerChris Lahey <clahey@src.gnome.org>2000-09-18 00:55:16 +0800
commit7912355008d54df720894d1334313801f594c8f2 (patch)
treefa34064a7066b77dbdf7762c620eb5b9b689f0c6 /addressbook/gui/widgets/Makefile.am
parent4f04a07954d6d577dfd99fbb85fe60db5873d137 (diff)
downloadgsoc2013-evolution-7912355008d54df720894d1334313801f594c8f2.tar
gsoc2013-evolution-7912355008d54df720894d1334313801f594c8f2.tar.gz
gsoc2013-evolution-7912355008d54df720894d1334313801f594c8f2.tar.bz2
gsoc2013-evolution-7912355008d54df720894d1334313801f594c8f2.tar.lz
gsoc2013-evolution-7912355008d54df720894d1334313801f594c8f2.tar.xz
gsoc2013-evolution-7912355008d54df720894d1334313801f594c8f2.tar.zst
gsoc2013-evolution-7912355008d54df720894d1334313801f594c8f2.zip
Fixed the paths of some .h #includes.
2000-09-15 Christopher James Lahey <clahey@helixcode.com> * contact-editor/e-contact-editor.h, contact-editor/e-contact-save-as.h, gui/widgets/e-addressbook-model.h, gui/widgets/e-minicard-view-widget.h, gui/widgets/e-minicard-view.h, gui/widgets/e-minicard.c, gui/widgets/e-minicard.h: Fixed the paths of some .h #includes. * gui/component/addressbook.c: Removed all of the code to actually create and display the correct view of the addressbook and moved it to the new class gui/widgets/e-addressbook-view.c. * gui/widgets/Makefile.am: Added everything necessary for e-addressbook-view.c and e-addressbook-view.h. * gui/widgets/e-addressbook-view.c, gui/widgets/e-addressbook-view.h: New class to deal with actual display of addresses and switching between card view and table view. * gui/widgets/e-minicard-view-widget.c: Made this deal more gracefully with having the book set to NULL. svn path=/trunk/; revision=5475
Diffstat (limited to 'addressbook/gui/widgets/Makefile.am')
-rw-r--r--addressbook/gui/widgets/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/addressbook/gui/widgets/Makefile.am b/addressbook/gui/widgets/Makefile.am
index 2d2cc902d0..9680a0a2dc 100644
--- a/addressbook/gui/widgets/Makefile.am
+++ b/addressbook/gui/widgets/Makefile.am
@@ -1,10 +1,13 @@
+CPPFLAGS = \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\"
+
INCLUDES = \
-DG_LOG_DOMAIN=\"e-minicard\" \
-I$(top_srcdir) \
- -I$(top_srcdir)/addressbook/backend \
- -I$(top_builddir)/addressbook/backend \
+ -I$(top_srcdir)/addressbook/backend/ebook \
-I$(top_srcdir)/addressbook/contact-editor \
-I$(top_srcdir)/widgets/e-text \
+ -I$(top_srcdir)/widgets/e-table \
-I$(top_srcdir)/widgets/e-reflow \
-I$(top_srcdir)/widgets/e-table \
-I$(top_srcdir)/widgets/misc \
@@ -16,6 +19,8 @@ noinst_LIBRARIES = \
libeminicard_a_SOURCES = \
e-addressbook-model.c \
e-addressbook-model.h \
+ e-addressbook-view.c \
+ e-addressbook-view.h \
e-minicard-control.c \
e-minicard-control.h \
e-minicard-label.c \