aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/widgets/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2002-11-06 16:17:14 +0800
committerChris Toshok <toshok@src.gnome.org>2002-11-06 16:17:14 +0800
commitd73b3bb496a3738d12442386231f3b2fa18967a6 (patch)
tree19e3144a5bd31fa137eabf81d575f1a5503d7448 /addressbook/gui/widgets/Makefile.am
parent4e57b96f83fb8d0f79b10d1b219062973a095e56 (diff)
downloadgsoc2013-evolution-d73b3bb496a3738d12442386231f3b2fa18967a6.tar
gsoc2013-evolution-d73b3bb496a3738d12442386231f3b2fa18967a6.tar.gz
gsoc2013-evolution-d73b3bb496a3738d12442386231f3b2fa18967a6.tar.bz2
gsoc2013-evolution-d73b3bb496a3738d12442386231f3b2fa18967a6.tar.lz
gsoc2013-evolution-d73b3bb496a3738d12442386231f3b2fa18967a6.tar.xz
gsoc2013-evolution-d73b3bb496a3738d12442386231f3b2fa18967a6.tar.zst
gsoc2013-evolution-d73b3bb496a3738d12442386231f3b2fa18967a6.zip
Port to GObject/gnome2.
2002-11-05 Chris Toshok <toshok@ximian.com> * gui/widgets/e-addressbook-model.[ch]: Port to GObject/gnome2. * gui/widgets/e-addressbook-reflow-adapter.c: Port to GObject/gnome2. * gui/widgets/e-addressbook-table-adapter.c: Port to GObject/gnome2. * gui/widgets/e-addressbook-util.c: Port to GObject/gnome2. * gui/widgets/e-addressbook-view.[ch]: Port to GObject/gnome2. * gui/widgets/e-minicard-control.c: Port to GObject/gnome2. * gui/widgets/e-minicard-label.[ch]: Port to GObject/gnome2. * gui/widgets/e-minicard-view-widget.[ch]: Port to GObject/gnome2. * gui/widgets/e-minicard-view.[ch]: Port to GObject/gnome2. * gui/widgets/e-minicard-widget-test.c: Port to GObject/gnome2. * gui/widgets/e-minicard-widget.c: Port to GObject/gnome2. * gui/widgets/e-minicard.[ch]: Port to GObject/gnome2. * gui/widgets/gal-view-factory-minicard.c: Port to GObject/gnome2. * gui/widgets/gal-view-minicard.c: Port to GObject/gnome2. * gui/widgets/test-minicard-label.c: Port to GObject/gnome2. * gui/widgets/test-minicard-view.c: Port to GObject/gnome2. * gui/widgets/test-minicard.c: Port to GObject/gnome2. * gui/widgets/test-reflow.c: Port to GObject/gnome2. * gui/widgets/Makefile.am: typical port stuff. add marshaller generation foo, dist it... * gui/widgets/.cvsignore: ignore the marshaller stuff. svn path=/trunk/; revision=18588
Diffstat (limited to 'addressbook/gui/widgets/Makefile.am')
-rw-r--r--addressbook/gui/widgets/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/addressbook/gui/widgets/Makefile.am b/addressbook/gui/widgets/Makefile.am
index e262e18f5c..eed44c04a2 100644
--- a/addressbook/gui/widgets/Makefile.am
+++ b/addressbook/gui/widgets/Makefile.am
@@ -18,6 +18,7 @@ noinst_LIBRARIES = \
libeminicard.a
libeminicard_a_SOURCES = \
+ e-addressbook-marshal.c \
e-addressbook-reflow-adapter.c \
e-addressbook-reflow-adapter.h \
e-addressbook-table-adapter.c \
@@ -45,6 +46,20 @@ libeminicard_a_SOURCES = \
gal-view-minicard.c \
gal-view-minicard.h
+# GLib marshalling cruft
+
+e-addressbook-marshal.h: e-addressbook-marshal.list
+ ( @GLIB_GENMARSHAL@ --prefix=e_addressbook_marshal e-addressbook-marshal.list --header > e-addressbook-marshal.tmp \
+ && mv e-addressbook-marshal.tmp e-addressbook-marshal.h ) \
+ || ( rm -f e-addressbook-marshal.tmp && exit 1 )
+
+e-addressbook-marshal.c: e-addressbook-marshal.h
+ ( @GLIB_GENMARSHAL@ --prefix=e_addressbook_marshal e-addressbook-marshal.list --body > e-addressbook-marshal.tmp \
+ && mv e-addressbook-marshal.tmp e-addressbook-marshal.c ) \
+ || ( rm -f e-addressbook-marshal.tmp && exit 1 )
+
+MARSHAL_GENERATED = e-addressbook-marshal.c e-addressbook-marshal.h
+
#noinst_PROGRAMS = \
# minicard-widget-test \
# minicard-label-test \
@@ -135,5 +150,5 @@ etspec_DATA= e-addressbook-view.etspec
EXTRA_DIST = \
$(glade_DATA) \
- $(etspec_DATA)
- \ No newline at end of file
+ $(etspec_DATA) \
+ e-addressbook-marshal.list