aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/widgets/Makefile.am
diff options
context:
space:
mode:
authorChristopher James Lahey <clahey@ximian.com>2001-05-08 12:58:41 +0800
committerChris Lahey <clahey@src.gnome.org>2001-05-08 12:58:41 +0800
commit3c0c62e2958b5dccca490908145c534022a85563 (patch)
tree421d5332f2518c99cfd6ac6dd4aa325f1a0a1a84 /addressbook/gui/widgets/Makefile.am
parent5d4895eb431adfbf2c7895d4257fa20a28f474f9 (diff)
downloadgsoc2013-evolution-3c0c62e2958b5dccca490908145c534022a85563.tar
gsoc2013-evolution-3c0c62e2958b5dccca490908145c534022a85563.tar.gz
gsoc2013-evolution-3c0c62e2958b5dccca490908145c534022a85563.tar.bz2
gsoc2013-evolution-3c0c62e2958b5dccca490908145c534022a85563.tar.lz
gsoc2013-evolution-3c0c62e2958b5dccca490908145c534022a85563.tar.xz
gsoc2013-evolution-3c0c62e2958b5dccca490908145c534022a85563.tar.zst
gsoc2013-evolution-3c0c62e2958b5dccca490908145c534022a85563.zip
Removed e-card-pairs.h since we're not using it.
2001-05-08 Christopher James Lahey <clahey@ximian.com> * backend/ebook/Makefile.am (libebookinclude_HEADERS): Removed e-card-pairs.h since we're not using it. * backend/ebook/e-book-view.c (e_book_view_check_listener_queue): Added break; to default: case here. * backend/ebook/e-card-simple.c, backend/ebook/e-card-simple.h: Added changed variable so as to avoid sync_card when possible. (e_card_simple_destroy): Free all the data here properly. (e_card_simple_get_arg): Slight simplification here. (fill_in_info, e_card_simple_arbitrary_foreach, e_card_simple_get_arbitrary): Call e_card_free_empty_lists here to save a bit of memory. * backend/ebook/e-card.c, backend/ebook/e-card.h: Fixed up includes a bit. (e_card_list_get_vcard, e_card_list_send): Added these functions for acting on a group of cards. (parse_org): Cleaned up this function a bit. (e_card_free_empty_lists): Added this function to delete unnecessary ELists and save a bit of memory. (e_v_object_get_child_value): Made this return NULL if not found instead of g_strdup(""). * contact-editor/e-contact-save-as.c, contact-editor/e-contact-save-as.h (e_contact_list_save_as): Added this function to save multiple contacts. * gui/widgets/Makefile.am: Commented out reflow test. (libeminicard_a_SOURCES): Added e-minicard-view-model.c and e-minicard-view-model.h. * gui/widgets/e-minicard-view-model.c, gui/widgets/e-minicard-view-model.h: Model for use in EMinicardView. * gui/widgets/e-minicard-view.c, gui/widgets/e-minicard-view.h: Reworked this to use the new EReflow stuff. * gui/widgets/e-minicard.c (e_minicard_event): Doesn't handle right click menus now. Emits a signal on the parent canvas item instead. * printing/e-contact-print-envelope.c, printing/e-contact-print-envelope.h (e_contact_print_envelope_list_dialog_new): Added this function to print multiple envelopes (only prints first for now.) * printing/e-contact-print.c, printing/e-contact-print.h (e_contact_print_card_list_dialog_new): Added this function to print multiple cards. Only prints the first for now. svn path=/trunk/; revision=9711
Diffstat (limited to 'addressbook/gui/widgets/Makefile.am')
-rw-r--r--addressbook/gui/widgets/Makefile.am38
1 files changed, 20 insertions, 18 deletions
diff --git a/addressbook/gui/widgets/Makefile.am b/addressbook/gui/widgets/Makefile.am
index 5fe7d9ea7c..fdb97866d3 100644
--- a/addressbook/gui/widgets/Makefile.am
+++ b/addressbook/gui/widgets/Makefile.am
@@ -27,6 +27,8 @@ libeminicard_a_SOURCES = \
e-minicard-label.h \
e-minicard-view-widget.c \
e-minicard-view-widget.h \
+ e-minicard-view-model.c \
+ e-minicard-view-model.h \
e-minicard-view.c \
e-minicard-view.h \
e-minicard-widget.c \
@@ -41,8 +43,8 @@ libeminicard_a_SOURCES = \
noinst_PROGRAMS = \
minicard-widget-test \
minicard-label-test \
- minicard-test \
- reflow-test
+ minicard-test
+# reflow-test
# minicard-view-test
minicard_label_test_SOURCES = \
@@ -71,22 +73,22 @@ minicard_test_LDADD = \
$(BONOBO_GNOME_LIBS) \
$(GNOME_PRINT_LIBS)
-reflow_test_SOURCES = \
- test-reflow.c
-
-reflow_test_LDADD = \
- libeminicard.a \
- $(top_builddir)/addressbook/backend/ebook/libebook.la \
- $(top_builddir)/e-util/libeutil.la \
- $(top_builddir)/libversit/libversit.la \
- $(top_builddir)/e-util/ename/libename.la \
- $(top_builddir)/addressbook/contact-editor/libecontacteditor.a \
- $(top_builddir)/addressbook/printing/libecontactprint.a \
- $(top_builddir)/widgets/misc/libemiscwidgets.a \
- $(top_builddir)/e-util/libeutil.la \
- $(EXTRA_GNOME_LIBS) \
- $(BONOBO_GNOME_LIBS) \
- $(GNOME_PRINT_LIBS)
+#reflow_test_SOURCES = \
+# test-reflow.c
+#
+#reflow_test_LDADD = \
+# libeminicard.a \
+# $(top_builddir)/addressbook/backend/ebook/libebook.la \
+# $(top_builddir)/e-util/libeutil.la \
+# $(top_builddir)/libversit/libversit.la \
+# $(top_builddir)/e-util/ename/libename.la \
+# $(top_builddir)/addressbook/contact-editor/libecontacteditor.a \
+# $(top_builddir)/addressbook/printing/libecontactprint.a \
+# $(top_builddir)/widgets/misc/libemiscwidgets.a \
+# $(top_builddir)/e-util/libeutil.la \
+# $(EXTRA_GNOME_LIBS) \
+# $(BONOBO_GNOME_LIBS) \
+# $(GNOME_PRINT_LIBS)
#minicard_view_test_SOURCES = \
# test-minicard-view.c