aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/widgets/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2003-02-06 07:48:14 +0800
committerDan Winship <danw@src.gnome.org>2003-02-06 07:48:14 +0800
commit675a9d147ab100372a7026688cbafc4665498c8b (patch)
tree4a923646ba9e5cb868630d100a8e92e4f062e6a5 /addressbook/gui/widgets/Makefile.am
parent9a08dd45d329cf425f15a3ccc63463a9b489340f (diff)
downloadgsoc2013-evolution-675a9d147ab100372a7026688cbafc4665498c8b.tar
gsoc2013-evolution-675a9d147ab100372a7026688cbafc4665498c8b.tar.gz
gsoc2013-evolution-675a9d147ab100372a7026688cbafc4665498c8b.tar.bz2
gsoc2013-evolution-675a9d147ab100372a7026688cbafc4665498c8b.tar.lz
gsoc2013-evolution-675a9d147ab100372a7026688cbafc4665498c8b.tar.xz
gsoc2013-evolution-675a9d147ab100372a7026688cbafc4665498c8b.tar.zst
gsoc2013-evolution-675a9d147ab100372a7026688cbafc4665498c8b.zip
Remove cruft. (gladedir, etspecdir): Remove definitions. (glade_DATA):
* gui/widgets/Makefile.am (INCLUDES): Remove cruft. (gladedir, etspecdir): Remove definitions. (glade_DATA): Empty, so remove it. * gui/widgets/e-addressbook-reflow-adapter.c: #include <string.h> (addressbook_get_property): Remove unused variable * gui/widgets/e-addressbook-view.c: #include <string.h> (get_selection_model): Add a g_return_val_if_reached. * gui/widgets/e-minicard.c: #include string.h, gtkmain.h, gnome-canvas-pixbuf.h (field_changed): s/gtk_object_unref/g_object_unref/ (get_left_width): Remove unused variable * gui/widgets/e-minicard-control.c: #include <string.h> (pstream_load, pstream_save): Use g_ascii_strcasecmp * gui/widgets/e-minicard-view.c: #include <string.h> * gui/widgets/e-minicard-view-widget.c (e_minicard_view_widget_new): s/gtk_type_new/g_object_new/ svn path=/trunk/; revision=19784
Diffstat (limited to 'addressbook/gui/widgets/Makefile.am')
-rw-r--r--addressbook/gui/widgets/Makefile.am39
1 files changed, 16 insertions, 23 deletions
diff --git a/addressbook/gui/widgets/Makefile.am b/addressbook/gui/widgets/Makefile.am
index aa3dbe464c..44938fb100 100644
--- a/addressbook/gui/widgets/Makefile.am
+++ b/addressbook/gui/widgets/Makefile.am
@@ -1,22 +1,20 @@
INCLUDES = \
- -DG_LOG_DOMAIN=\"e-minicard\" \
- -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
- -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
- -DEVOLUTION_DATADIR=\""$(datadir)"\" \
- -DEVOLUTION_IMAGESDIR=\""$(datadir)"/evolution-$(BASE_VERSION)/images\" \
- -DEVOLUTION_GALVIEWSDIR=\""$(datadir)"/evolution-$(BASE_VERSION)/views\" \
- -I$(top_srcdir) \
- -I$(top_srcdir)/addressbook/backend \
- -I$(top_builddir)/addressbook/backend \
- -I$(top_srcdir)/addressbook/gui/contact-editor \
- -I$(top_srcdir)/addressbook/gui/merging \
- -I$(top_srcdir)/addressbook/gui/component \
- -I$(top_srcdir)/widgets/misc \
- -I$(top_builddir)/shell \
- -DG_DISABLE_DEPRECATED \
- -DGTK_DISABLE_DEPRECATED \
- -DLIBGNOME_DISABLE_DEPRECATED \
- -DLIBGNOMEUI_DISABLE_DEPRECATED \
+ -DG_LOG_DOMAIN=\"e-minicard\" \
+ -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
+ -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\" \
+ -DEVOLUTION_GALVIEWSDIR=\""$(viewsdir)"\" \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/addressbook/backend \
+ -I$(top_builddir)/addressbook/backend \
+ -I$(top_srcdir)/addressbook/gui/contact-editor \
+ -I$(top_srcdir)/addressbook/gui/merging \
+ -I$(top_srcdir)/addressbook/gui/component \
+ -I$(top_srcdir)/widgets/misc \
+ -I$(top_builddir)/shell \
+ -DG_DISABLE_DEPRECATED \
+ -DGTK_DISABLE_DEPRECATED \
+ -DLIBGNOME_DISABLE_DEPRECATED \
+ -DLIBGNOMEUI_DISABLE_DEPRECATED \
$(EVOLUTION_ADDRESSBOOK_CFLAGS)
noinst_LIBRARIES = \
@@ -154,13 +152,8 @@ MARSHAL_GENERATED = e-addressbook-marshal.c e-addressbook-marshal.h
# $(top_builddir)/addressbook/gui/merging/libecardmerging.a \
# $(EVOLUTION_ADDRESSBOOK_LIBS)
-gladedir = $(datadir)/evolution-$(BASE_VERSION)/glade
-glade_DATA =
-
-etspecdir = $(datadir)/evolution-$(BASE_VERSION)/etspec
etspec_DATA= e-addressbook-view.etspec
EXTRA_DIST = \
- $(glade_DATA) \
$(etspec_DATA) \
e-addressbook-marshal.list