aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/widgets/Makefile.am
diff options
context:
space:
mode:
authorHans Petter Jansson <hpj@ximian.com>2004-06-04 11:28:29 +0800
committerHans Petter <hansp@src.gnome.org>2004-06-04 11:28:29 +0800
commit99ec0bcf5e38a79c1a5965e5e95b8a839a68bc3e (patch)
tree9a687a4b96e28bb55e16c1f2c29fd83e61dbd2d7 /addressbook/gui/widgets/Makefile.am
parentf9d996db29d5e8a9697409b1dbe25b99df0a1387 (diff)
downloadgsoc2013-evolution-99ec0bcf5e38a79c1a5965e5e95b8a839a68bc3e.tar
gsoc2013-evolution-99ec0bcf5e38a79c1a5965e5e95b8a839a68bc3e.tar.gz
gsoc2013-evolution-99ec0bcf5e38a79c1a5965e5e95b8a839a68bc3e.tar.bz2
gsoc2013-evolution-99ec0bcf5e38a79c1a5965e5e95b8a839a68bc3e.tar.lz
gsoc2013-evolution-99ec0bcf5e38a79c1a5965e5e95b8a839a68bc3e.tar.xz
gsoc2013-evolution-99ec0bcf5e38a79c1a5965e5e95b8a839a68bc3e.tar.zst
gsoc2013-evolution-99ec0bcf5e38a79c1a5965e5e95b8a839a68bc3e.zip
Fixes #53643 and #26903.
2004-06-03 Hans Petter Jansson <hpj@ximian.com> Fixes #53643 and #26903. * gui/search/addresstypes.xml: category -> category_list * gui/search/e-addressbook-search-dialog.c (get_widget): Get filter rule from parent view. (eab_search_dialog_set_property): Implement. (eab_search_dialog_get_property): Impleent. (eab_search_dialog_class_init): Set up property methods. (get_query): Get filter rule from parent view. (eab_search_dialog_init): Don't get the filter widget here, wait until parent view property is set. (eab_search_dialog_new): Don't poke the parent view in, set it as a property instead. (eab_search_dialog_dispose): No longer needs to unref rule. * gui/search/e-addressbook-search-dialog.c: EABSearchDialog no longer needs to keep rule internally. * gui/widgets/Makefile.am: Set SEARCH_RULE_DIR define. * gui/widgets/e-addressbook-view.c (eab_view_new): Set up filter rule and context. (eab_view_peek_search_context): Implement. (eab_view_peek_search_rule): Implement. * gui/widgets/e-addressbook-view.h: Keep track of filter rule and context. Add protos for added API. svn path=/trunk/; revision=26207
Diffstat (limited to 'addressbook/gui/widgets/Makefile.am')
-rw-r--r--addressbook/gui/widgets/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/addressbook/gui/widgets/Makefile.am b/addressbook/gui/widgets/Makefile.am
index ce5cc32275..6842ce14d5 100644
--- a/addressbook/gui/widgets/Makefile.am
+++ b/addressbook/gui/widgets/Makefile.am
@@ -1,3 +1,5 @@
+ruledir = $(privdatadir)
+
INCLUDES = \
-DG_LOG_DOMAIN=\"eab-widgets\" \
-DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
@@ -12,6 +14,7 @@ INCLUDES = \
-I$(top_srcdir)/addressbook/gui/component \
-I$(top_srcdir)/widgets/misc \
-I$(top_builddir)/shell \
+ -DSEARCH_RULE_DIR=\"$(ruledir)\" \
$(EVOLUTION_ADDRESSBOOK_CFLAGS)
CORBA_COMPOSER_SOURCE_H = \