aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/contact-list-editor/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2002-11-06 16:22:36 +0800
committerChris Toshok <toshok@src.gnome.org>2002-11-06 16:22:36 +0800
commit5ae49242fcdbdb41bdfa642f43eb1805dc209534 (patch)
treed6f115e266025e092f92eb2a12492c207ac7f7bc /addressbook/gui/contact-list-editor/Makefile.am
parent4d53826308a95d959a986b7b7cc57abf80e85862 (diff)
downloadgsoc2013-evolution-5ae49242fcdbdb41bdfa642f43eb1805dc209534.tar
gsoc2013-evolution-5ae49242fcdbdb41bdfa642f43eb1805dc209534.tar.gz
gsoc2013-evolution-5ae49242fcdbdb41bdfa642f43eb1805dc209534.tar.bz2
gsoc2013-evolution-5ae49242fcdbdb41bdfa642f43eb1805dc209534.tar.lz
gsoc2013-evolution-5ae49242fcdbdb41bdfa642f43eb1805dc209534.tar.xz
gsoc2013-evolution-5ae49242fcdbdb41bdfa642f43eb1805dc209534.tar.zst
gsoc2013-evolution-5ae49242fcdbdb41bdfa642f43eb1805dc209534.zip
ignore the marshal generated stuff.
2002-11-05 Chris Toshok <toshok@ximian.com> * gui/contact-list-editor/.cvsignore: ignore the marshal generated stuff. * gui/contact-list-editor/Makefile.am: typical port stuff. add marshaller generation foo, dist it... * gui/contact-list-editor/e-contact-list-editor.[ch]: Port to GObject/gnome2. * gui/contact-list-editor/e-contact-list-model.[ch]: Port to GObject/gnome2. svn path=/trunk/; revision=18590
Diffstat (limited to 'addressbook/gui/contact-list-editor/Makefile.am')
-rw-r--r--addressbook/gui/contact-list-editor/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/addressbook/gui/contact-list-editor/Makefile.am b/addressbook/gui/contact-list-editor/Makefile.am
index c87f352879..b469b2a330 100644
--- a/addressbook/gui/contact-list-editor/Makefile.am
+++ b/addressbook/gui/contact-list-editor/Makefile.am
@@ -21,9 +21,25 @@ noinst_LIBRARIES = \
libecontactlisteditor_a_SOURCES = \
e-contact-list-editor.c \
e-contact-list-editor.h \
+ e-contact-list-editor-marshal.c \
e-contact-list-model.c \
e-contact-list-model.h
+# GLib marshalling cruft
+
+e-contact-list-editor-marshal.h: e-contact-list-editor-marshal.list
+ ( @GLIB_GENMARSHAL@ --prefix=ecle_marshal e-contact-list-editor-marshal.list --header > e-contact-list-editor-marshal.tmp \
+ && mv e-contact-list-editor-marshal.tmp e-contact-list-editor-marshal.h ) \
+ || ( rm -f e-contact-list-editor-marshal.tmp && exit 1 )
+
+e-contact-list-editor-marshal.c: e-contact-list-editor-marshal.h
+ ( @GLIB_GENMARSHAL@ --prefix=ecle_marshal e-contact-list-editor-marshal.list --body > e-contact-list-editor-marshal.tmp \
+ && mv e-contact-list-editor-marshal.tmp e-contact-list-editor-marshal.c ) \
+ || ( rm -f e-contact-list-editor-marshal.tmp && exit 1 )
+
+MARSHAL_GENERATED = e-contact-list-editor-marshal.c e-contact-list-editor-marshal.h
+
+
iconsdir = $(datadir)/images/evolution
gladedir = $(datadir)/evolution/glade
@@ -34,5 +50,9 @@ glade_DATA = \
etspecdir = $(datadir)/evolution/etspec
etspec_DATA = e-contact-list-editor.etspec
+BUILT_SOURCES = $(MARSHAL_GENERATED)
+CLEANFILES = $(BUILT_SOURCES)
+
EXTRA_DIST = $(glade_DATA) \
- $(etspec_DATA)
+ $(etspec_DATA) \
+ e-contact-list-editor-marshal.list