aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/contact-list-editor/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-06-19 02:36:55 +0800
committerTor Lillqvist <tml@src.gnome.org>2005-06-19 02:36:55 +0800
commit40a550f2bb6dc1770767e824a2c77307a5dffa9b (patch)
tree32ca6787bceb50158eb49202f44c102bd873cb65 /addressbook/gui/contact-list-editor/Makefile.am
parent8340689e4a19748936e4a192390f87e8393f24d7 (diff)
downloadgsoc2013-evolution-40a550f2bb6dc1770767e824a2c77307a5dffa9b.tar
gsoc2013-evolution-40a550f2bb6dc1770767e824a2c77307a5dffa9b.tar.gz
gsoc2013-evolution-40a550f2bb6dc1770767e824a2c77307a5dffa9b.tar.bz2
gsoc2013-evolution-40a550f2bb6dc1770767e824a2c77307a5dffa9b.tar.lz
gsoc2013-evolution-40a550f2bb6dc1770767e824a2c77307a5dffa9b.tar.xz
gsoc2013-evolution-40a550f2bb6dc1770767e824a2c77307a5dffa9b.tar.zst
gsoc2013-evolution-40a550f2bb6dc1770767e824a2c77307a5dffa9b.zip
gui/component/Makefile.am gui/contact-editor/Makefile.am
2005-06-18 Tor Lillqvist <tml@novell.com> * gui/component/Makefile.am * gui/contact-editor/Makefile.am * gui/contact-list-editor/Makefile.am * gui/merging/Makefile.am * gui/search/Makefile.am * gui/widgets/Makefile.am: Prune unnecessary and nonexistent directories from the -I options. Prune pathname macros not used in the sources in that directory from the -D options. * gui/component/Makefile.am * gui/contact-editor/Makefile.am * gui/contact-list-editor/Makefile.am * util/Makefile.am: Use NO_UNDEFINED. Link with all necessary libraries. * gui/component/Makefile.am: Use Win32-specific hack to work around MSYS feature in the gconftool invocation. * gui/contact-editor/Makefile.am * gui/contact-list-editor/Makefile.am: Use bootstrap library libevolution-addressbook on Win32. * gui/contact-editor/Makefile.am * gui/contact-list-editor/Makefile.am * util/Makefile.am: Use privsolib_LTLIBRARIES instead of privlib_LTLIBRARIES (see ../ChangeLog). svn path=/trunk/; revision=29546
Diffstat (limited to 'addressbook/gui/contact-list-editor/Makefile.am')
-rw-r--r--addressbook/gui/contact-list-editor/Makefile.am23
1 files changed, 16 insertions, 7 deletions
diff --git a/addressbook/gui/contact-list-editor/Makefile.am b/addressbook/gui/contact-list-editor/Makefile.am
index 10069eaca1..71516c33bb 100644
--- a/addressbook/gui/contact-list-editor/Makefile.am
+++ b/addressbook/gui/contact-list-editor/Makefile.am
@@ -1,22 +1,20 @@
+if OS_WIN32
+WIN32_BOOTSTRAP_LIBS = $(top_builddir)/win32/libevolution-addressbook.la
+endif
+
INCLUDES = \
-I$(top_srcdir) \
-I$(top_srcdir)/widgets \
-I$(top_srcdir)/addressbook/ \
- -I$(top_srcdir)/addressbook/backend \
- -I$(top_builddir)/addressbook/backend \
-I$(top_srcdir)/addressbook/gui/merging \
-I$(top_srcdir)/addressbook/gui/contact-editor \
-I$(top_builddir)/shell \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
-DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
- -DEVOLUTION_DATADIR=\""$(datadir)"\" \
- -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\" \
- -DEVOLUTION_UIDIR=\""$(evolutionuidir)\"" \
- -DPREFIX=\""$(prefix)"\" \
-DG_LOG_DOMAIN=\"contact-list-editor\" \
$(EVOLUTION_ADDRESSBOOK_CFLAGS)
-privlib_LTLIBRARIES = \
+privsolib_LTLIBRARIES = \
libecontactlisteditor.la
libecontactlisteditor_la_SOURCES = \
@@ -26,6 +24,17 @@ libecontactlisteditor_la_SOURCES = \
e-contact-list-model.c \
e-contact-list-model.h
+libecontactlisteditor_la_LDFLAGS = $(NO_UNDEFINED)
+
+libecontactlisteditor_la_LIBADD = \
+ $(WIN32_BOOTSTRAP_LIBS) \
+ $(top_builddir)/addressbook/util/libeabutil.la \
+ $(top_builddir)/addressbook/gui/contact-editor/libecontacteditor.la \
+ $(top_builddir)/widgets/table/libetable.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(EVOLUTION_ADDRESSBOOK_LIBS)
+
MARSHAL_GENERATED = e-contact-list-editor-marshal.c e-contact-list-editor-marshal.h
@EVO_MARSHAL_RULE@