aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/contact-list-editor/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2007-11-29 04:54:19 +0800
committerMatthew Barnes <mbarnes@src.gnome.org>2007-11-29 04:54:19 +0800
commit4bca50f1c5060efbfe2f0c9d011e4d51f1e8be0f (patch)
tree670e42776b90bc2b22ab060828d944b8b1c6af6d /addressbook/gui/contact-list-editor/Makefile.am
parentcfbb09abfdba072800304ab46146323b3b2ff785 (diff)
downloadgsoc2013-evolution-4bca50f1c5060efbfe2f0c9d011e4d51f1e8be0f.tar
gsoc2013-evolution-4bca50f1c5060efbfe2f0c9d011e4d51f1e8be0f.tar.gz
gsoc2013-evolution-4bca50f1c5060efbfe2f0c9d011e4d51f1e8be0f.tar.bz2
gsoc2013-evolution-4bca50f1c5060efbfe2f0c9d011e4d51f1e8be0f.tar.lz
gsoc2013-evolution-4bca50f1c5060efbfe2f0c9d011e4d51f1e8be0f.tar.xz
gsoc2013-evolution-4bca50f1c5060efbfe2f0c9d011e4d51f1e8be0f.tar.zst
gsoc2013-evolution-4bca50f1c5060efbfe2f0c9d011e4d51f1e8be0f.zip
** Fixes bug #489652
2007-11-28 Matthew Barnes <mbarnes@redhat.com> ** Fixes bug #489652 Migrate the contact list editor from ETable to GtkTreeView and fix some HIG issues. * addressbook/gui/contact-list-editor/Makefile.am: Remove e-contact-list-editor.etspec Remove e-contact-list-editor-marshal.list * addressbook/gui/contact-list-editor/contact-list-editor.glade: Fix some HIG issues and give all the widgets proper names. * addressbook/gui/contact-list-editor/e-contact-list-model.c: * addressbook/gui/contact-list-editor/e-contact-list-model.h: EContactListModel is now a subclass of GtkListStore. * addressbook/gui/contact-list-editor/e-contact-list.c: * addressbook/gui/contact-list-editor/e-contact-list.h: Use a GtkTreeView instead of an ETable for displaying members. Refactor everything; see bug #489652 for more details. svn path=/trunk/; revision=34610
Diffstat (limited to 'addressbook/gui/contact-list-editor/Makefile.am')
-rw-r--r--addressbook/gui/contact-list-editor/Makefile.am9
1 files changed, 1 insertions, 8 deletions
diff --git a/addressbook/gui/contact-list-editor/Makefile.am b/addressbook/gui/contact-list-editor/Makefile.am
index 71516c33bb..76122c2421 100644
--- a/addressbook/gui/contact-list-editor/Makefile.am
+++ b/addressbook/gui/contact-list-editor/Makefile.am
@@ -10,7 +10,6 @@ INCLUDES = \
-I$(top_srcdir)/addressbook/gui/contact-editor \
-I$(top_builddir)/shell \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
- -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
-DG_LOG_DOMAIN=\"contact-list-editor\" \
$(EVOLUTION_ADDRESSBOOK_CFLAGS)
@@ -35,15 +34,9 @@ libecontactlisteditor_la_LIBADD = \
$(top_builddir)/e-util/libeutil.la \
$(EVOLUTION_ADDRESSBOOK_LIBS)
-MARSHAL_GENERATED = e-contact-list-editor-marshal.c e-contact-list-editor-marshal.h
-@EVO_MARSHAL_RULE@
-
glade_DATA = contact-list-editor.glade
-etspec_DATA = e-contact-list-editor.etspec
BUILT_SOURCES = $(MARSHAL_GENERATED)
CLEANFILES = $(BUILT_SOURCES)
-EXTRA_DIST = $(glade_DATA) \
- $(etspec_DATA) \
- e-contact-list-editor-marshal.list
+EXTRA_DIST = $(glade_DATA)