aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/contact-editor/Makefile.am
diff options
context:
space:
mode:
authorMilan Crha <mcrha@redhat.com>2014-03-25 19:04:58 +0800
committerMilan Crha <mcrha@redhat.com>2014-03-25 19:04:58 +0800
commit8692b1cb72654888f0dab31843bdf05d3ac2a888 (patch)
tree3e172e8085830cf0770cf0a7ab04bd714753d3a9 /addressbook/gui/contact-editor/Makefile.am
parent399b1a6fc593a9c5e692923120346e0386f578e5 (diff)
downloadgsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.gz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.bz2
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.lz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.xz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.zst
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.zip
Add an --enable-code-coverage configure option to enable gcov support
When enabled, this will compile all libraries/binaries with the necessary gcc and ld flags to enable code coverage support using gcov.
Diffstat (limited to 'addressbook/gui/contact-editor/Makefile.am')
-rw-r--r--addressbook/gui/contact-editor/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/addressbook/gui/contact-editor/Makefile.am b/addressbook/gui/contact-editor/Makefile.am
index c8499b7da4..e62b6cf058 100644
--- a/addressbook/gui/contact-editor/Makefile.am
+++ b/addressbook/gui/contact-editor/Makefile.am
@@ -11,7 +11,8 @@ libecontacteditor_la_CPPFLAGS = \
-DG_LOG_DOMAIN=\"contact-editor\" \
$(EVOLUTION_DATA_SERVER_CFLAGS) \
$(GNOME_PLATFORM_CFLAGS) \
- $(GTKHTML_CFLAGS)
+ $(GTKHTML_CFLAGS) \
+ $(CODE_COVERAGE_CFLAGS)
libecontacteditor_la_SOURCES = \
eab-editor.c \
@@ -25,7 +26,7 @@ libecontacteditor_la_SOURCES = \
e-contact-editor-dyntable.h \
e-contact-editor-dyntable.c
-libecontacteditor_la_LDFLAGS = -avoid-version $(NO_UNDEFINED)
+libecontacteditor_la_LDFLAGS = -avoid-version $(NO_UNDEFINED) $(CODE_COVERAGE_LDFLAGS)
libecontacteditor_la_LIBADD = \
$(top_builddir)/e-util/libevolution-util.la \