aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/contact-editor/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2003-02-06 07:47:32 +0800
committerDan Winship <danw@src.gnome.org>2003-02-06 07:47:32 +0800
commit9ef99937403649cf8ffaea419c5c804def6f1439 (patch)
tree200cda1d1f78ac6d24dacacd4db361bbb47cf2f3 /addressbook/gui/contact-editor/Makefile.am
parent3dd0e5884e06ec8a5376362da694a487b27b8ca6 (diff)
downloadgsoc2013-evolution-9ef99937403649cf8ffaea419c5c804def6f1439.tar
gsoc2013-evolution-9ef99937403649cf8ffaea419c5c804def6f1439.tar.gz
gsoc2013-evolution-9ef99937403649cf8ffaea419c5c804def6f1439.tar.bz2
gsoc2013-evolution-9ef99937403649cf8ffaea419c5c804def6f1439.tar.lz
gsoc2013-evolution-9ef99937403649cf8ffaea419c5c804def6f1439.tar.xz
gsoc2013-evolution-9ef99937403649cf8ffaea419c5c804def6f1439.tar.zst
gsoc2013-evolution-9ef99937403649cf8ffaea419c5c804def6f1439.zip
Remove some cruft. rename ICONSDIR to IMAGESDIR. (images_DATA): Install
* gui/contact-editor/Makefile.am (INCLUDES): Remove some cruft. rename ICONSDIR to IMAGESDIR. (images_DATA): Install arrow.png in imagesdir instead of privdatadir. * gui/contact-editor/e-contact-quick-add.c: #include <string.h> * gui/contact-editor/e-contact-editor.c: #include <string.h> (e_contact_editor_init): s/EVOLUTION_ICONSDIR/EVOLUTION_IMAGESDIR/ (e_contact_editor_new): s/gtk_object_ref/g_object_ref/ (_replace_button): Look in imagesdir, not privdatadir (_phone_arrow_pressed): Remove call to deprecated gtk_check_menu_item_set_show_toggle. (_email_arrow_pressed): Likewise (_address_arrow_pressed): Likewise (set_address_field): Remove unused variable (enable_widget): s/gtk_entry_set_editable/gtk_editable_set_editable/ * gui/contact-editor/e-contact-editor-address.c (e_contact_editor_address_init): s/EVOLUTION_ICONSDIR/EVOLUTION_IMAGESDIR (e_contact_editor_address_set_property): s/gtk_entry_set_editable/gtk_editable_set_editable/ * gui/contact-editor/e-contact-editor-fullname.c (e_contact_editor_fullname_init): s/EVOLUTION_ICONSDIR/EVOLUTION_IMAGESDIR (e_contact_editor_fullname_set_property): Likewise. svn path=/trunk/; revision=19781
Diffstat (limited to 'addressbook/gui/contact-editor/Makefile.am')
-rw-r--r--addressbook/gui/contact-editor/Makefile.am13
1 files changed, 4 insertions, 9 deletions
diff --git a/addressbook/gui/contact-editor/Makefile.am b/addressbook/gui/contact-editor/Makefile.am
index 0b478a3479..c7f7acac71 100644
--- a/addressbook/gui/contact-editor/Makefile.am
+++ b/addressbook/gui/contact-editor/Makefile.am
@@ -7,10 +7,8 @@ INCLUDES = \
-I$(top_srcdir)/widgets/e-table \
-I$(top_builddir)/shell \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
- -DDATADIR=\""$(datadir)"\" \
-DEVOLUTION_DATADIR=\""$(datadir)"\" \
- -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
- -DEVOLUTIONDIR=\""$(evolutiondir)"\" \
+ -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\" \
-DEVOLUTION_UIDIR=\""$(evolution_uidir)\"" \
-DG_LOG_DOMAIN=\"contact-editor\" \
-DG_DISABLE_DEPRECATED \
@@ -49,10 +47,7 @@ e-contact-editor-marshal.c: e-contact-editor-marshal.h
MARSHAL_GENERATED = e-contact-editor-marshal.c e-contact-editor-marshal.h
-evolutiondir = $(datadir)/evolution-$(BASE_VERSION)
-evolution_DATA = arrow.png
-
-gladedir = $(datadir)/evolution-$(BASE_VERSION)/glade
+images_DATA = arrow.png
glade_DATA = \
contact-editor.glade \
@@ -62,6 +57,6 @@ glade_DATA = \
BUILT_SOURCES = $(MARSHAL_GENERATED)
CLEANFILES = $(BUILT_SOURCES)
-EXTRA_DIST= $(evolution_DATA) \
- $(glade_DATA) \
+EXTRA_DIST= $(images_DATA) \
+ $(glade_DATA) \
e-contact-editor-marshal.list