aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/select-names/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-02-07 07:24:45 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-02-07 07:24:45 +0800
commit292e7184f665e30b1e1239b34065ada089e31b29 (patch)
treebe3687ad227828c76688c68bedf40b9e0256f1a4 /addressbook/gui/component/select-names/Makefile.am
parent75b60575be726c73ace0700c52e526f869c1448f (diff)
downloadgsoc2013-evolution-292e7184f665e30b1e1239b34065ada089e31b29.tar
gsoc2013-evolution-292e7184f665e30b1e1239b34065ada089e31b29.tar.gz
gsoc2013-evolution-292e7184f665e30b1e1239b34065ada089e31b29.tar.bz2
gsoc2013-evolution-292e7184f665e30b1e1239b34065ada089e31b29.tar.lz
gsoc2013-evolution-292e7184f665e30b1e1239b34065ada089e31b29.tar.xz
gsoc2013-evolution-292e7184f665e30b1e1239b34065ada089e31b29.tar.zst
gsoc2013-evolution-292e7184f665e30b1e1239b34065ada089e31b29.zip
Use different tmp file names so these rules can be executed in parallel
* backend/ebook/Makefile.am (e-book-marshal.c, e-book-marshal.h): Use different tmp file names so these rules can be executed in parallel without interfering with each otehr. * backend/pas/Makefile.am: Make the ORBit compilation work properly with parallel makes (i.e. make sure it does not spawn multiple orbit-idl processes on the same IDL file at the same time). * gui/component/select-names/Makefile.am: Likewise. * backend/ebook/Makefile.am: Likewise. svn path=/trunk/; revision=19834
Diffstat (limited to 'addressbook/gui/component/select-names/Makefile.am')
-rw-r--r--addressbook/gui/component/select-names/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/addressbook/gui/component/select-names/Makefile.am b/addressbook/gui/component/select-names/Makefile.am
index 7c03ec9992..d9e9887a26 100644
--- a/addressbook/gui/component/select-names/Makefile.am
+++ b/addressbook/gui/component/select-names/Makefile.am
@@ -3,17 +3,18 @@
idl_DATA = \
Evolution-Addressbook-SelectNames.idl
-IDL_GENERATED = \
- Evolution-Addressbook-SelectNames.h \
+IDL_GENERATED_H = \
+ Evolution-Addressbook-SelectNames.h
+IDL_GENERATED_C = \
Evolution-Addressbook-SelectNames-common.c \
Evolution-Addressbook-SelectNames-skels.c \
Evolution-Addressbook-SelectNames-stubs.c
+IDL_GENERATED = $(IDL_GENERATED_C) $(IDL_GENERATED_H)
-Evolution-Addressbook-SelectNames-impl.o: Evolution-Addressbook-SelectNames.h
-
-$(IDL_GENERATED): $(idl_DATA)
+$(IDL_GENERATED_H): $(idl_DATA)
$(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) \
$(srcdir)/Evolution-Addressbook-SelectNames.idl
+$(IDL_GENERATED_C): $(IDL_GENERATED_H)
server_in_files = GNOME_Evolution_Addressbook_SelectNames.server.in.in