aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/select-names/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2003-01-10 03:17:01 +0800
committerChris Toshok <toshok@src.gnome.org>2003-01-10 03:17:01 +0800
commit52bf62c8226956d81e0d58133de32139800acbb5 (patch)
tree5919cb13931776b036d04d95e4ed04b8ee05972b /addressbook/gui/component/select-names/Makefile.am
parentfef77b9924ba63a06e57b596c00dd7b92be276f5 (diff)
downloadgsoc2013-evolution-52bf62c8226956d81e0d58133de32139800acbb5.tar
gsoc2013-evolution-52bf62c8226956d81e0d58133de32139800acbb5.tar.gz
gsoc2013-evolution-52bf62c8226956d81e0d58133de32139800acbb5.tar.bz2
gsoc2013-evolution-52bf62c8226956d81e0d58133de32139800acbb5.tar.lz
gsoc2013-evolution-52bf62c8226956d81e0d58133de32139800acbb5.tar.xz
gsoc2013-evolution-52bf62c8226956d81e0d58133de32139800acbb5.tar.zst
gsoc2013-evolution-52bf62c8226956d81e0d58133de32139800acbb5.zip
comment out the factory oaf_server, and change the location of the
2003-01-09 Chris Toshok <toshok@ximian.com> * gui/component/select-names/GNOME_Evolution_Addressbook_SelectNames.server.in.in: comment out the factory oaf_server, and change the location of the SelectNames controls to be OAFIID:GNOME_Evolution_Addressbook_Factory so the normal addressbook.so will create them. * gui/component/select-names/Makefile.am (libeselectnames_la_SOURCES): remove the e-select-names-factory.[ch] stuff for the time being. * gui/component/component-factory.c (factory): we're now (for the time being) the factory for the select names control. svn path=/trunk/; revision=19369
Diffstat (limited to 'addressbook/gui/component/select-names/Makefile.am')
-rw-r--r--addressbook/gui/component/select-names/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/addressbook/gui/component/select-names/Makefile.am b/addressbook/gui/component/select-names/Makefile.am
index ad3bb4f8f0..5972f3f4db 100644
--- a/addressbook/gui/component/select-names/Makefile.am
+++ b/addressbook/gui/component/select-names/Makefile.am
@@ -1,5 +1,7 @@
# CORBA stuff
+componentdir = $(COMPONENT_DIR)
+
idl_DATA = \
Evolution-Addressbook-SelectNames.idl
@@ -20,7 +22,7 @@ server_in_files = GNOME_Evolution_Addressbook_SelectNames.server.in.in
serverdir = $(libdir)/bonobo/servers
server_DATA = $(server_in_files:.server.in.in=.server)
$(server_in_files:.server.in.in=.server.in): $(server_in_files)
- sed -e "s|\@LIBEXECDIR\@|$(libexecdir)|" $< > $@
+ sed -e "s|\@COMPONENTDIR\@|$(componentdir)|" $< > $@
@INTLTOOL_SERVER_RULE@
@@ -56,8 +58,6 @@ libeselectnames_la_SOURCES = \
e-select-names-bonobo.h \
e-select-names-completion.c \
e-select-names-completion.h \
- e-select-names-factory.c \
- e-select-names-factory.h \
e-select-names-manager.c \
e-select-names-manager.h \
e-select-names-marshal.c \
@@ -74,6 +74,12 @@ libeselectnames_la_SOURCES = \
e-simple-card-bonobo.c \
e-simple-card-bonobo.h
+# We'll need these again when we split out the select names control
+# into its own shlib factory, but for now they're redundant.
+#
+# e-select-names-factory.c
+# e-select-names-factory.h
+
# GLib marshalling cruft
e-select-names-marshal.h: e-select-names-marshal.list