aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/select-names/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2004-05-29 12:43:04 +0800
committerChris Toshok <toshok@src.gnome.org>2004-05-29 12:43:04 +0800
commit3feccd8c20fdd464521369678195af32ac067125 (patch)
treecb72748c475c9528f689a6c88ad27137b67064f6 /addressbook/gui/component/select-names/Makefile.am
parent9e6feeb9fb6bf39d4809850f0833bed8a8a8387b (diff)
downloadgsoc2013-evolution-3feccd8c20fdd464521369678195af32ac067125.tar
gsoc2013-evolution-3feccd8c20fdd464521369678195af32ac067125.tar.gz
gsoc2013-evolution-3feccd8c20fdd464521369678195af32ac067125.tar.bz2
gsoc2013-evolution-3feccd8c20fdd464521369678195af32ac067125.tar.lz
gsoc2013-evolution-3feccd8c20fdd464521369678195af32ac067125.tar.xz
gsoc2013-evolution-3feccd8c20fdd464521369678195af32ac067125.tar.zst
gsoc2013-evolution-3feccd8c20fdd464521369678195af32ac067125.zip
call e_select_names_model_load_contacts after setting
2004-05-28 Chris Toshok <toshok@ximian.com> * gui/component/select-names/e-select-names-bonobo.c (entry_set_property_fn): call e_select_names_model_load_contacts after setting text/addresses/destinations. * gui/component/select-names/e-select-names-model.c (name_and_email_simple_query_cb): new function, ripped from the 1.4 e-destination stuff. (book_opened): new function, fire off eab_name_and_email_query for each item in our model (that doesn't represent a contact already). (e_select_names_model_load_contacts): new function, open the default addressbook (yeah yeah, i know we should open something different/more.) (e_select_names_cancel_contacts_load): new (unimplemented, and how do we implement it?) function. * gui/component/select-names/e-select-names-model.h: add prototypes for e_select_names_model_load_contacts and e_select_names_cancel_contacts_load. * gui/component/select-names/e-select-names.c (set_book): call get_query_string and set the book and query in a single call to g_object_set, just because we can/should. (update_query): reimplement in terms of get_query_string. (get_query_string): new function, build up the query string. * gui/component/select-names/Makefile.am (INCLUDES): add $(top_srcdir)/addressbook/util to INCLUDES. svn path=/trunk/; revision=26129
Diffstat (limited to 'addressbook/gui/component/select-names/Makefile.am')
-rw-r--r--addressbook/gui/component/select-names/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/addressbook/gui/component/select-names/Makefile.am b/addressbook/gui/component/select-names/Makefile.am
index 8cd1235be2..c8d0b83052 100644
--- a/addressbook/gui/component/select-names/Makefile.am
+++ b/addressbook/gui/component/select-names/Makefile.am
@@ -33,6 +33,7 @@ INCLUDES = \
-I$(top_srcdir)/addressbook/contact-editor \
-I$(top_srcdir)/addressbook/backend \
-I$(top_builddir)/addressbook/backend \
+ -I$(top_srcdir)/addressbook/util \
-DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\" \
-DEVOLUTION_DATADIR=\""$(datadir)"\" \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \