aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2003-10-30 04:16:40 +0800
committerChris Toshok <toshok@src.gnome.org>2003-10-30 04:16:40 +0800
commit02af33ab9c7c6356629fe208aae836f3c844f3a8 (patch)
treedf865abb018b08227d01c7793df934b1b6e26291 /addressbook/gui/component/Makefile.am
parent302a9b1ed51e68e26c3d15fc6a6daf875fd7febc (diff)
downloadgsoc2013-evolution-02af33ab9c7c6356629fe208aae836f3c844f3a8.tar
gsoc2013-evolution-02af33ab9c7c6356629fe208aae836f3c844f3a8.tar.gz
gsoc2013-evolution-02af33ab9c7c6356629fe208aae836f3c844f3a8.tar.bz2
gsoc2013-evolution-02af33ab9c7c6356629fe208aae836f3c844f3a8.tar.lz
gsoc2013-evolution-02af33ab9c7c6356629fe208aae836f3c844f3a8.tar.xz
gsoc2013-evolution-02af33ab9c7c6356629fe208aae836f3c844f3a8.tar.zst
gsoc2013-evolution-02af33ab9c7c6356629fe208aae836f3c844f3a8.zip
ifdef the smime code with HAVE_NSS.
2003-10-29 Chris Toshok <toshok@ximian.com> * gui/component/component-factory.c (factory): ifdef the smime code with HAVE_NSS. * gui/component/Makefile.am (libevolution_addressbook_la_LIBADD): conditionally include libevolution-smime.la. svn path=/trunk/; revision=23124
Diffstat (limited to 'addressbook/gui/component/Makefile.am')
-rw-r--r--addressbook/gui/component/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/addressbook/gui/component/Makefile.am b/addressbook/gui/component/Makefile.am
index bf9064a132..0e16c5ac92 100644
--- a/addressbook/gui/component/Makefile.am
+++ b/addressbook/gui/component/Makefile.am
@@ -41,8 +41,12 @@ libevolution_addressbook_la_SOURCES = \
# $(top_builddir)/addressbook/printing/libecontactprint.la
+if ENABLE_SMIME
+SMIME_LIB=$(top_builddir)/smime/gui/libevolution-smime.la
+endif
+
libevolution_addressbook_la_LIBADD = \
- $(top_builddir)/smime/gui/libevolution-smime.la \
+ $(SMIME_LIB) \
$(top_builddir)/addressbook/gui/component/select-names/libeselectnames.la \
$(top_builddir)/shell/libeshell.la \
$(top_builddir)/addressbook/gui/merging/libeabbookmerging.la \