aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-04-21 07:18:51 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-04-21 07:18:51 +0800
commita2ee0e2ec91ae9dec0bd10cbc716651dfdf0932a (patch)
tree4aadfc1ee70b6d886decf95820964183181c215c /addressbook/gui/component/Makefile.am
parente38b6187f5dbe154e07ec7b2d5fb036df0597265 (diff)
downloadgsoc2013-evolution-a2ee0e2ec91ae9dec0bd10cbc716651dfdf0932a.tar
gsoc2013-evolution-a2ee0e2ec91ae9dec0bd10cbc716651dfdf0932a.tar.gz
gsoc2013-evolution-a2ee0e2ec91ae9dec0bd10cbc716651dfdf0932a.tar.bz2
gsoc2013-evolution-a2ee0e2ec91ae9dec0bd10cbc716651dfdf0932a.tar.lz
gsoc2013-evolution-a2ee0e2ec91ae9dec0bd10cbc716651dfdf0932a.tar.xz
gsoc2013-evolution-a2ee0e2ec91ae9dec0bd10cbc716651dfdf0932a.tar.zst
gsoc2013-evolution-a2ee0e2ec91ae9dec0bd10cbc716651dfdf0932a.zip
Use "e-minicard" as the log domain.
2000-04-18 Federico Mena Quintero <federico@helixcode.com> * gui/minicard/Makefile.am (INCLUDES): Use "e-minicard" as the log domain. * gui/component/Makefile.am (INCLUDES): Use "evolution-addressbook" as the log domain. * backend/pas/Makefile.am: Build libpas.a, not a shared library. Do not install any header files. (INCLUDES): Remove spurious include paths. * backend/pas/*.[ch]: Fix includes. * backend/ebook/Makefile.am: Do not install the test programs. Fixed some include weirdness. * backend/ebook/*.[ch]: Fix includes. * contact-editor/Makefile.am (INCLUDES): Set the log domain to "contact-editor". (INCLUDES): Fix. * contact-editor/*.[ch]: Fix includes. * gui/minicard/*.[ch]: Fix includes. svn path=/trunk/; revision=2529
Diffstat (limited to 'addressbook/gui/component/Makefile.am')
-rw-r--r--addressbook/gui/component/Makefile.am29
1 files changed, 15 insertions, 14 deletions
diff --git a/addressbook/gui/component/Makefile.am b/addressbook/gui/component/Makefile.am
index 486cc9d528..c20864912b 100644
--- a/addressbook/gui/component/Makefile.am
+++ b/addressbook/gui/component/Makefile.am
@@ -1,12 +1,13 @@
-INCLUDES = \
- $(EXTRA_GNOME_CFLAGS) \
- $(GNOME_INCLUDEDIR) \
- -I$(top_srcdir)/widgets/e-text \
- -I$(top_srcdir)/e-util \
- -I$(top_srcdir) \
+INCLUDES = \
+ -DG_LOG_DOMAIN=\"evolution-addressbook\" \
+ $(EXTRA_GNOME_CFLAGS) \
+ $(GNOME_INCLUDEDIR) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets/e-text \
-I$(top_srcdir)/addressbook/gui/minicard \
-I$(top_srcdir)/addressbook/contact-editor \
- -I$(top_srcdir)/addressbook/backend/ebook \
+ -I$(top_srcdir)/addressbook/backend \
+ -I$(top_builddir)/addressbook/backend \
$(BONOBO_HTML_GNOME_CFLAGS) \
-DEVOLUTION_VERSION=\""$(VERSION)"\" \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
@@ -22,13 +23,13 @@ evolution_addressbook_SOURCES = \
addressbook.c \
addressbook.h
-evolution_addressbook_LDADD = \
- $(EXTRA_GNOME_LIBS) \
- $(BONOBO_HTML_GNOME_LIBS) \
- $(top_builddir)/addressbook/gui/minicard/libeminicard.a \
- $(top_builddir)/widgets/e-text/libetext.a \
- $(top_builddir)/e-util/libeutil.la \
- $(top_builddir)/addressbook/backend/ebook/libebook.la \
+evolution_addressbook_LDADD = \
+ $(EXTRA_GNOME_LIBS) \
+ $(BONOBO_HTML_GNOME_LIBS) \
+ $(top_builddir)/addressbook/gui/minicard/libeminicard.a \
+ $(top_builddir)/widgets/e-text/libetext.a \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/addressbook/backend/ebook/libebook.la \
$(top_builddir)/addressbook/contact-editor/libecontacteditor.a \
$(top_builddir)/libversit/libversit.la