aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2002-11-27 10:10:21 +0800
committerChris Toshok <toshok@src.gnome.org>2002-11-27 10:10:21 +0800
commit83a54e15a95b22f91b5ef68a2687a7af9f9d1b43 (patch)
treeb4eba3bbdfaa138636b8c58514f6b36577eba0ad /addressbook/gui/component/Makefile.am
parent1c0c2cc2f45e462abcaf2fd9dc2e5542c722ea49 (diff)
downloadgsoc2013-evolution-83a54e15a95b22f91b5ef68a2687a7af9f9d1b43.tar
gsoc2013-evolution-83a54e15a95b22f91b5ef68a2687a7af9f9d1b43.tar.gz
gsoc2013-evolution-83a54e15a95b22f91b5ef68a2687a7af9f9d1b43.tar.bz2
gsoc2013-evolution-83a54e15a95b22f91b5ef68a2687a7af9f9d1b43.tar.lz
gsoc2013-evolution-83a54e15a95b22f91b5ef68a2687a7af9f9d1b43.tar.xz
gsoc2013-evolution-83a54e15a95b22f91b5ef68a2687a7af9f9d1b43.tar.zst
gsoc2013-evolution-83a54e15a95b22f91b5ef68a2687a7af9f9d1b43.zip
use new schema for completion/uris. (uris_listener): same.
2002-11-26 Chris Toshok <toshok@ximian.com> * gui/component/select-names/e-select-names-manager.c (read_completion_books_from_db): use new schema for completion/uris. (uris_listener): same. * gui/component/select-names/e-select-names.h: Convert to GtkDialog from GnomeDialog. * gui/component/select-names/e-select-names.c: Convert to GtkDialog from GnomeDialog. (folder_selected): use new schema for last_used_uri. (e_select_names_init): same. (e_select_names_set_default): use pango markup to set bold/not-bold. (e_select_names_add_section): don't bother creating an EEntry, we can use pango and a normal label. This also keeps us from wrapping "contacts ->" at the '-'. * gui/component/apps_evolution_addressbook.schemas: new file. * gui/component/Makefile.am: add the schema stuff. svn path=/trunk/; revision=18939
Diffstat (limited to 'addressbook/gui/component/Makefile.am')
-rw-r--r--addressbook/gui/component/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/addressbook/gui/component/Makefile.am b/addressbook/gui/component/Makefile.am
index 2dc9972641..b5ec044cd5 100644
--- a/addressbook/gui/component/Makefile.am
+++ b/addressbook/gui/component/Makefile.am
@@ -68,6 +68,18 @@ evolution_addressbook_LDADD = \
# not done yet:
# $(top_builddir)/filter/libfilter.la
+# GConf schemas
+
+schemadir = $(GCONF_SCHEMA_FILE_DIR)
+schema_DATA = apps_evolution_addressbook.schemas
+
+install-data-local:
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schema_DATA) ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p; \
+ done \
+ fi
+
server_in_files = GNOME_Evolution_Addressbook.server.in.in
serverdir = $(libdir)/bonobo/servers