aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2003-02-06 07:48:52 +0800
committerDan Winship <danw@src.gnome.org>2003-02-06 07:48:52 +0800
commit13fb419aa00a75cee734a775930b2e048b884254 (patch)
treefddfa1e3ed3871b24327025a70eb1328cc299931 /addressbook/gui/component/Makefile.am
parent0873dd0b655a282a3c05914ead1dcaf0d5e772ba (diff)
downloadgsoc2013-evolution-13fb419aa00a75cee734a775930b2e048b884254.tar
gsoc2013-evolution-13fb419aa00a75cee734a775930b2e048b884254.tar.gz
gsoc2013-evolution-13fb419aa00a75cee734a775930b2e048b884254.tar.bz2
gsoc2013-evolution-13fb419aa00a75cee734a775930b2e048b884254.tar.lz
gsoc2013-evolution-13fb419aa00a75cee734a775930b2e048b884254.tar.xz
gsoc2013-evolution-13fb419aa00a75cee734a775930b2e048b884254.tar.zst
gsoc2013-evolution-13fb419aa00a75cee734a775930b2e048b884254.zip
Remove cruft, rename ICONSDIR to IMAGESDIR. (serverdir, gladedir): Remove
* gui/component/Makefile.am (INCLUDES): Remove cruft, rename ICONSDIR to IMAGESDIR. (serverdir, gladedir): Remove defintions. * gui/component/addressbook-component.c (IS_CONTACT_TYPE): use g_ascii_strcasecmp (add_creatable_item): s/ICONSDIR/IMAGESDIR/ * gui/component/component-factory.c: #include <string.h> * gui/component/e-address-widget.c: Likewise. (e_address_widget_destroy): s/gtk_idle_remove/g_source_remove/ (e_address_widget_schedule_query): s/gtk_idle_add/g_idle_add/ svn path=/trunk/; revision=19786
Diffstat (limited to 'addressbook/gui/component/Makefile.am')
-rw-r--r--addressbook/gui/component/Makefile.am54
1 files changed, 23 insertions, 31 deletions
diff --git a/addressbook/gui/component/Makefile.am b/addressbook/gui/component/Makefile.am
index f831c19c6e..d53fb4c7ac 100644
--- a/addressbook/gui/component/Makefile.am
+++ b/addressbook/gui/component/Makefile.am
@@ -1,35 +1,29 @@
SUBDIRS = select-names
INCLUDES = \
- -DG_LOG_DOMAIN=\"evolution-addressbook\" \
- -DPREFIX=\"$(prefix)\" \
- -DSYSCONFDIR=\"$(sysconfdir)\" \
- -DDATADIR=\"$(datadir)\" \
- -DLIBDIR=\"$(libdir)\" \
- -I$(top_srcdir) \
- -I$(top_builddir) \
- -I$(top_srcdir)/shell \
- -I$(top_builddir)/shell \
- -I$(top_srcdir)/widgets/misc \
- -I$(top_srcdir)/addressbook/gui/contact-editor \
- -I$(top_srcdir)/addressbook/gui/contact-list-editor \
- -I$(top_srcdir)/addressbook/gui/minicard \
- -I$(top_srcdir)/addressbook/gui/widgets \
- -I$(top_srcdir)/addressbook/backend \
- -I$(top_builddir)/addressbook/backend \
- -DEVOLUTION_DATADIR=\""$(datadir)"\" \
- -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
- -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
- -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
- -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
- -DCAMEL_PROVIDERDIR=\""$(providerdir)"\" \
- -DEVOLUTION_IMAGESDIR=\""$(datadir)"/evolution-$(BASE_VERSION)/images\" \
- -DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
- $(LDAP_CFLAGS) \
- -DG_DISABLE_DEPRECATED \
- -DGTK_DISABLE_DEPRECATED \
- -DLIBGNOME_DISABLE_DEPRECATED \
- -DLIBGNOMEUI_DISABLE_DEPRECATED \
+ -DG_LOG_DOMAIN=\"evolution-addressbook\" \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/shell \
+ -I$(top_builddir)/shell \
+ -I$(top_srcdir)/widgets/misc \
+ -I$(top_srcdir)/addressbook/gui/contact-editor \
+ -I$(top_srcdir)/addressbook/gui/contact-list-editor \
+ -I$(top_srcdir)/addressbook/gui/minicard \
+ -I$(top_srcdir)/addressbook/gui/widgets \
+ -I$(top_srcdir)/addressbook/backend \
+ -I$(top_builddir)/addressbook/backend \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
+ -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
+ $(LDAP_CFLAGS) \
+ -DG_DISABLE_DEPRECATED \
+ -DGTK_DISABLE_DEPRECATED \
+ -DLIBGNOME_DISABLE_DEPRECATED \
+ -DLIBGNOMEUI_DISABLE_DEPRECATED \
$(EVOLUTION_ADDRESSBOOK_CFLAGS)
component_LTLIBRARIES = libevolution-addressbook.la
@@ -88,14 +82,12 @@ install-data-local:
server_in_files = GNOME_Evolution_Addressbook.server.in.in
-serverdir = $(libdir)/bonobo/servers
server_DATA = $(server_in_files:.server.in.in=.server)
$(server_in_files:.server.in.in=.server.in): $(server_in_files)
sed -e "s|\@COMPONENTDIR\@|$(componentdir)|" $< > $@
@INTLTOOL_SERVER_RULE@
-gladedir = $(datadir)/evolution-$(BASE_VERSION)/glade
glade_DATA = ldap-config.glade
EXTRA_DIST = \