aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@src.gnome.org>2000-05-07 05:24:53 +0800
committerChris Toshok <toshok@src.gnome.org>2000-05-07 05:24:53 +0800
commit83d1c04306a2652b188806df76efa2c192b979e5 (patch)
tree88c4c7ce8a8e63f7fc82acabe45347b08217fac5 /addressbook/gui/component/Makefile.am
parent342a2293ce7913814380fd95582d4c3d98674835 (diff)
downloadgsoc2013-evolution-83d1c04306a2652b188806df76efa2c192b979e5.tar
gsoc2013-evolution-83d1c04306a2652b188806df76efa2c192b979e5.tar.gz
gsoc2013-evolution-83d1c04306a2652b188806df76efa2c192b979e5.tar.bz2
gsoc2013-evolution-83d1c04306a2652b188806df76efa2c192b979e5.tar.lz
gsoc2013-evolution-83d1c04306a2652b188806df76efa2c192b979e5.tar.xz
gsoc2013-evolution-83d1c04306a2652b188806df76efa2c192b979e5.tar.zst
gsoc2013-evolution-83d1c04306a2652b188806df76efa2c192b979e5.zip
ignore evolution-addressbook.pure
* gui/component/.cvsignore: ignore evolution-addressbook.pure * gui/component/Makefile.am: add support for generating evolution-addressbook.pure. svn path=/trunk/; revision=2835
Diffstat (limited to 'addressbook/gui/component/Makefile.am')
-rw-r--r--addressbook/gui/component/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/addressbook/gui/component/Makefile.am b/addressbook/gui/component/Makefile.am
index 8b247a50b8..931394f6b1 100644
--- a/addressbook/gui/component/Makefile.am
+++ b/addressbook/gui/component/Makefile.am
@@ -54,3 +54,15 @@ glade_DATA = ldap-server-dialog.glade
EXTRA_DIST = \
addressbook.gnorba \
addressbook.oafinfo
+
+if ENABLE_PURIFY
+PLINK = $(LIBTOOL) --mode=link $(PURIFY) $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
+
+all-local: evolution-addressbook.pure
+
+evolution-addressbook.pure: evolution-addressbook
+ @rm -f evolution-addressbook.pure
+ $(PLINK) $(evolution_addressbook_LDFLAGS) $(evolution_addressbook_OBJECTS) $(evolution_addressbook_LDADD) $(LIBS)
+
+endif
+