aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/Makefile.am
diff options
context:
space:
mode:
authorChristopher James Lahey <clahey@helixcode.com>2000-05-07 08:41:35 +0800
committerChris Lahey <clahey@src.gnome.org>2000-05-07 08:41:35 +0800
commit51aa4cb7c216c9518516e0bada53ae97849a2bd0 (patch)
treef39f505d25dd132e0cbf5701a4663145bfac47e4 /addressbook/gui/component/Makefile.am
parent7c90b45149b4a77de70db43a773a92f8977fdf48 (diff)
downloadgsoc2013-evolution-51aa4cb7c216c9518516e0bada53ae97849a2bd0.tar
gsoc2013-evolution-51aa4cb7c216c9518516e0bada53ae97849a2bd0.tar.gz
gsoc2013-evolution-51aa4cb7c216c9518516e0bada53ae97849a2bd0.tar.bz2
gsoc2013-evolution-51aa4cb7c216c9518516e0bada53ae97849a2bd0.tar.lz
gsoc2013-evolution-51aa4cb7c216c9518516e0bada53ae97849a2bd0.tar.xz
gsoc2013-evolution-51aa4cb7c216c9518516e0bada53ae97849a2bd0.tar.zst
gsoc2013-evolution-51aa4cb7c216c9518516e0bada53ae97849a2bd0.zip
Made a NULL callback just mean to not call back.
2000-05-07 Christopher James Lahey <clahey@helixcode.com> * backend/ebook/e-book.c: Made a NULL callback just mean to not call back. * backend/ebook/e-card-simple.c, backend/ebook/e-card-simple.h: Reordered fields. Added a get_const function to get a constant string that persists until the simple is destroyed. * gui/component/Makefile.am: Added e-addressbook-model.c and e-addressbook-model.h and all of the libraries and includes that they are dependent on. * gui/component/addressbook-factory.c: Initialize e cursors. * gui/component/addressbook.c: Added inactive code to display an ETable view of the addressbook. svn path=/trunk/; revision=2844
Diffstat (limited to 'addressbook/gui/component/Makefile.am')
-rw-r--r--addressbook/gui/component/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/addressbook/gui/component/Makefile.am b/addressbook/gui/component/Makefile.am
index 931394f6b1..5a42c7e002 100644
--- a/addressbook/gui/component/Makefile.am
+++ b/addressbook/gui/component/Makefile.am
@@ -7,6 +7,7 @@ INCLUDES = \
$(GNOME_INCLUDEDIR) \
-I$(top_srcdir) \
-I$(top_srcdir)/widgets/e-text \
+ -I$(top_srcdir)/widgets/e-table \
-I$(top_srcdir)/addressbook/gui/minicard \
-I$(top_srcdir)/addressbook/contact-editor \
-I$(top_srcdir)/addressbook/backend \
@@ -23,6 +24,8 @@ bin_PROGRAMS = \
evolution_addressbook_SOURCES = \
e-ldap-server-dialog.c \
+ e-addressbook-model.c \
+ e-addressbook-model.h \
addressbook-factory.c \
addressbook.c \
addressbook.h
@@ -32,6 +35,7 @@ evolution_addressbook_LDADD = \
$(BONOBO_HTML_GNOME_LIBS) \
$(top_builddir)/addressbook/gui/minicard/libeminicard.a \
$(top_builddir)/widgets/e-text/libetext.a \
+ $(top_builddir)/widgets/e-table/libetable.a \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/addressbook/backend/ebook/libebook.la \
$(top_builddir)/addressbook/ename/libename.la \