aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2000-05-25 13:55:59 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2000-05-25 13:55:59 +0800
commitbb241192eb773d7f0d178306dd55f9ca8e31c1f0 (patch)
tree4201777027364eeea243b2f625bb373bca30ef6d /addressbook/gui/component/Makefile.am
parente90eea58a2109961faa8632ac5e5783d9970366b (diff)
downloadgsoc2013-evolution-bb241192eb773d7f0d178306dd55f9ca8e31c1f0.tar
gsoc2013-evolution-bb241192eb773d7f0d178306dd55f9ca8e31c1f0.tar.gz
gsoc2013-evolution-bb241192eb773d7f0d178306dd55f9ca8e31c1f0.tar.bz2
gsoc2013-evolution-bb241192eb773d7f0d178306dd55f9ca8e31c1f0.tar.lz
gsoc2013-evolution-bb241192eb773d7f0d178306dd55f9ca8e31c1f0.tar.xz
gsoc2013-evolution-bb241192eb773d7f0d178306dd55f9ca8e31c1f0.tar.zst
gsoc2013-evolution-bb241192eb773d7f0d178306dd55f9ca8e31c1f0.zip
Reorganized the shell to allow dynamic registration of storages and
folder types, and changed all the components to work with the new setup. svn path=/trunk/; revision=3199
Diffstat (limited to 'addressbook/gui/component/Makefile.am')
-rw-r--r--addressbook/gui/component/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/addressbook/gui/component/Makefile.am b/addressbook/gui/component/Makefile.am
index 1a1752ea07..c122fa571c 100644
--- a/addressbook/gui/component/Makefile.am
+++ b/addressbook/gui/component/Makefile.am
@@ -6,6 +6,9 @@ INCLUDES = \
$(EXTRA_GNOME_CFLAGS) \
$(GNOME_INCLUDEDIR) \
-I$(top_srcdir) \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/shell \
+ -I$(top_builddir)/shell \
-I$(top_srcdir)/widgets/e-text \
-I$(top_srcdir)/widgets/e-table \
-I$(top_srcdir)/addressbook/gui/minicard \
@@ -27,11 +30,21 @@ evolution_addressbook_SOURCES = \
e-ldap-server-dialog.h \
e-addressbook-model.c \
e-addressbook-model.h \
+ addressbook-component.c \
+ addressbook-component.h \
addressbook-factory.c \
addressbook.c \
addressbook.h
+# FIXME We should make a libeshell library instead of this gross hack.
+SHELL_OBJS = \
+ $(top_builddir)/shell/Evolution-common.o \
+ $(top_builddir)/shell/Evolution-stubs.o \
+ $(top_builddir)/shell/Evolution-skels.o \
+ $(top_builddir)/shell/evolution-shell-component.o
+
evolution_addressbook_LDADD = \
+ $(SHELL_OBJS) \
$(EXTRA_GNOME_LIBS) \
$(BONOBO_HTML_GNOME_LIBS) \
$(top_builddir)/addressbook/gui/minicard/libeminicard.a \