aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2002-11-16 06:13:52 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2002-11-16 06:13:52 +0800
commita47eb7a9a182c9d124fa8c98c852b0bdcfa245f4 (patch)
treed5ca0296231f54bd117f2af90f40e08e535d6721 /addressbook/gui/component/Makefile.am
parenta0e079bb116d721bbeb6931d4664cd1943c16309 (diff)
downloadgsoc2013-evolution-a47eb7a9a182c9d124fa8c98c852b0bdcfa245f4.tar
gsoc2013-evolution-a47eb7a9a182c9d124fa8c98c852b0bdcfa245f4.tar.gz
gsoc2013-evolution-a47eb7a9a182c9d124fa8c98c852b0bdcfa245f4.tar.bz2
gsoc2013-evolution-a47eb7a9a182c9d124fa8c98c852b0bdcfa245f4.tar.lz
gsoc2013-evolution-a47eb7a9a182c9d124fa8c98c852b0bdcfa245f4.tar.xz
gsoc2013-evolution-a47eb7a9a182c9d124fa8c98c852b0bdcfa245f4.tar.zst
gsoc2013-evolution-a47eb7a9a182c9d124fa8c98c852b0bdcfa245f4.zip
Added rule to generate GNOME_Evolution_Addressbook.server.in from
* gui/component/Makefile.am: Added rule to generate GNOME_Evolution_Addressbook.server.in from GNOME_Evolution_Addressbook.server.in.in, substituting @LIBEXECDIR@. * GNOME_Evolution_Addressbook.server.in.in: Renamed from GNOME_Evolution_Addressbook.server.in. Added @LIBEXECDIR@ before the location of the executable. * gui/component/select-names/select-names.glade: Ported to Glade 2. * gui/component/select-names/recipient.glade: Ported to Glade 2. svn path=/trunk/; revision=18794
Diffstat (limited to 'addressbook/gui/component/Makefile.am')
-rw-r--r--addressbook/gui/component/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/addressbook/gui/component/Makefile.am b/addressbook/gui/component/Makefile.am
index c3be7a7f81..2dc9972641 100644
--- a/addressbook/gui/component/Makefile.am
+++ b/addressbook/gui/component/Makefile.am
@@ -27,7 +27,7 @@ INCLUDES = \
$(LDAP_CFLAGS) \
$(EVOLUTION_ADDRESSBOOK_CFLAGS)
-bin_PROGRAMS = \
+libexec_PROGRAMS = \
evolution-addressbook
evolution_addressbook_SOURCES = \
@@ -68,11 +68,13 @@ evolution_addressbook_LDADD = \
# not done yet:
# $(top_builddir)/filter/libfilter.la
-@INTLTOOL_SERVER_RULE@
+server_in_files = GNOME_Evolution_Addressbook.server.in.in
-serversdir = $(libdir)/bonobo/servers
-server_in_files = GNOME_Evolution_Addressbook.server.in
-servers_DATA = $(server_in_files:.server.in=.server)
+serverdir = $(libdir)/bonobo/servers
+server_DATA = $(server_in_files:.server.in.in=.server)
+$(server_in_files:.server.in.in=.server.in): $(server_in_files)
+ sed -e "s|\@LIBEXECDIR\@|$(libexecdir)|" $< > $@
+@INTLTOOL_SERVER_RULE@
gladedir = $(datadir)/evolution/glade
glade_DATA = ldap-config.glade
@@ -84,7 +86,7 @@ etspec_DATA = addressbook-config.etspec
EXTRA_DIST = \
$(glade_DATA) \
- $(servers_DATA) \
+ $(server_DATA) \
$(server_in_files) \
$(etspec_DATA)