aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2002-11-06 16:26:18 +0800
committerChris Toshok <toshok@src.gnome.org>2002-11-06 16:26:18 +0800
commit3f73fe7fd078c0c5a91b2714dbb1c7ab25267d42 (patch)
tree6a881563c902748b9e93f9b42e56881c34204791 /addressbook/gui/component/Makefile.am
parent5ae49242fcdbdb41bdfa642f43eb1805dc209534 (diff)
downloadgsoc2013-evolution-3f73fe7fd078c0c5a91b2714dbb1c7ab25267d42.tar
gsoc2013-evolution-3f73fe7fd078c0c5a91b2714dbb1c7ab25267d42.tar.gz
gsoc2013-evolution-3f73fe7fd078c0c5a91b2714dbb1c7ab25267d42.tar.bz2
gsoc2013-evolution-3f73fe7fd078c0c5a91b2714dbb1c7ab25267d42.tar.lz
gsoc2013-evolution-3f73fe7fd078c0c5a91b2714dbb1c7ab25267d42.tar.xz
gsoc2013-evolution-3f73fe7fd078c0c5a91b2714dbb1c7ab25267d42.tar.zst
gsoc2013-evolution-3f73fe7fd078c0c5a91b2714dbb1c7ab25267d42.zip
ignore the new .server file.
2002-11-05 Chris Toshok <toshok@ximian.com> * gui/component/.cvsignore: ignore the new .server file. * gui/component/Makefile.am: typical port stuff. switch the .oaf to .server, and leave out a lot of libs so we can actually get things linking. * gui/component/GNOME_Evolution_Addressbook.server.in: rename .oaf.in here. * gui/component/addressbook-component.c: Port to GObject/gnome2. * gui/component/addressbook-config.c: Port to GObject/gnome2. * gui/component/addressbook-factory.c: Port to GObject/gnome2. * gui/component/addressbook-storage.c: Port to GObject/gnome2. * gui/component/addressbook.[ch]: Port to GObject/gnome2. * gui/component/e-address-popup.[ch]: Port to GObject/gnome2. * gui/component/e-address-widget.[ch]: Port to GObject/gnome2. * gui/component/e-cardlist-model.h: Port to GObject/gnome2. svn path=/trunk/; revision=18591
Diffstat (limited to 'addressbook/gui/component/Makefile.am')
-rw-r--r--addressbook/gui/component/Makefile.am28
1 files changed, 17 insertions, 11 deletions
diff --git a/addressbook/gui/component/Makefile.am b/addressbook/gui/component/Makefile.am
index 842d0489b5..445c47c83a 100644
--- a/addressbook/gui/component/Makefile.am
+++ b/addressbook/gui/component/Makefile.am
@@ -2,6 +2,10 @@ SUBDIRS = select-names
INCLUDES = \
-DG_LOG_DOMAIN=\"evolution-addressbook\" \
+ -DPREFIX=\"$(prefix)\" \
+ -DSYSCONFDIR=\"$(sysconfdir)\" \
+ -DDATADIR=\"$(datadir)\" \
+ -DLIBDIR=\"$(libdir)\" \
-I$(top_srcdir) \
-I$(top_builddir) \
-I$(top_srcdir)/shell \
@@ -48,27 +52,29 @@ evolution_addressbook_LDADD = \
$(top_builddir)/shell/libeshell.la \
$(top_builddir)/addressbook/gui/widgets/libeminicard.a \
$(top_builddir)/addressbook/backend/ebook/libebook.la \
- $(top_builddir)/camel/libcamel.la \
$(top_builddir)/e-util/ename/libename.la \
$(top_builddir)/addressbook/gui/contact-list-editor/libecontactlisteditor.a \
$(top_builddir)/addressbook/gui/contact-editor/libecontacteditor.a \
$(top_builddir)/libversit/libversit.a \
$(top_builddir)/widgets/misc/libemiscwidgets.a \
- $(top_builddir)/addressbook/printing/libecontactprint.a \
- $(top_builddir)/addressbook/gui/search/libeaddressbooksearch.a \
$(top_builddir)/addressbook/gui/merging/libecardmerging.a \
- $(top_builddir)/filter/libfilter.la \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/widgets/menus/libmenus.la \
$(EVOLUTION_ADDRESSBOOK_LIBS) $(LDAP_LIBS)
-evolution_addressbook_LDFLAGS = `gnome-config --libs gdk_pixbuf` -export-dynamic
+# not done yet:
+# $(top_builddir)/addressbook/gui/search/libeaddressbooksearch.a
+# $(top_builddir)/filter/libfilter.la
+# $(top_builddir)/addressbook/printing/libecontactprint.a
+# $(top_builddir)/camel/libcamel.la
-@XML_I18N_MERGE_OAF_RULE@
+#evolution_addressbook_LDFLAGS = `gnome-config --libs gdk_pixbuf` -export-dynamic
-oafdir = $(datadir)/oaf
-oaf_in_files = GNOME_Evolution_Addressbook.oaf.in
-oaf_DATA = $(oaf_in_files:.oaf.in=.oaf)
+@INTLTOOL_SERVER_RULE@
+
+serversdir = $(libdir)/bonobo/servers
+server_in_files = GNOME_Evolution_Addressbook.server.in
+servers_DATA = $(server_in_files:.server.in=.server)
gladedir = $(datadir)/evolution/glade
glade_DATA = ldap-config.glade
@@ -80,8 +86,8 @@ etspec_DATA = addressbook-config.etspec
EXTRA_DIST = \
$(glade_DATA) \
- $(oaf_DATA) \
- $(oaf_in_files) \
+ $(servers_DATA) \
+ $(server_in_files) \
$(etspec_DATA)
if ENABLE_PURIFY