aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-06-19 02:36:55 +0800
committerTor Lillqvist <tml@src.gnome.org>2005-06-19 02:36:55 +0800
commit40a550f2bb6dc1770767e824a2c77307a5dffa9b (patch)
tree32ca6787bceb50158eb49202f44c102bd873cb65 /addressbook/gui/component/Makefile.am
parent8340689e4a19748936e4a192390f87e8393f24d7 (diff)
downloadgsoc2013-evolution-40a550f2bb6dc1770767e824a2c77307a5dffa9b.tar
gsoc2013-evolution-40a550f2bb6dc1770767e824a2c77307a5dffa9b.tar.gz
gsoc2013-evolution-40a550f2bb6dc1770767e824a2c77307a5dffa9b.tar.bz2
gsoc2013-evolution-40a550f2bb6dc1770767e824a2c77307a5dffa9b.tar.lz
gsoc2013-evolution-40a550f2bb6dc1770767e824a2c77307a5dffa9b.tar.xz
gsoc2013-evolution-40a550f2bb6dc1770767e824a2c77307a5dffa9b.tar.zst
gsoc2013-evolution-40a550f2bb6dc1770767e824a2c77307a5dffa9b.zip
gui/component/Makefile.am gui/contact-editor/Makefile.am
2005-06-18 Tor Lillqvist <tml@novell.com> * gui/component/Makefile.am * gui/contact-editor/Makefile.am * gui/contact-list-editor/Makefile.am * gui/merging/Makefile.am * gui/search/Makefile.am * gui/widgets/Makefile.am: Prune unnecessary and nonexistent directories from the -I options. Prune pathname macros not used in the sources in that directory from the -D options. * gui/component/Makefile.am * gui/contact-editor/Makefile.am * gui/contact-list-editor/Makefile.am * util/Makefile.am: Use NO_UNDEFINED. Link with all necessary libraries. * gui/component/Makefile.am: Use Win32-specific hack to work around MSYS feature in the gconftool invocation. * gui/contact-editor/Makefile.am * gui/contact-list-editor/Makefile.am: Use bootstrap library libevolution-addressbook on Win32. * gui/contact-editor/Makefile.am * gui/contact-list-editor/Makefile.am * util/Makefile.am: Use privsolib_LTLIBRARIES instead of privlib_LTLIBRARIES (see ../ChangeLog). svn path=/trunk/; revision=29546
Diffstat (limited to 'addressbook/gui/component/Makefile.am')
-rw-r--r--addressbook/gui/component/Makefile.am24
1 files changed, 16 insertions, 8 deletions
diff --git a/addressbook/gui/component/Makefile.am b/addressbook/gui/component/Makefile.am
index 42f0f1713e..89d7b26dad 100644
--- a/addressbook/gui/component/Makefile.am
+++ b/addressbook/gui/component/Makefile.am
@@ -2,20 +2,14 @@ INCLUDES = \
-DG_LOG_DOMAIN=\"evolution-addressbook\" \
-I$(top_srcdir) \
-I$(top_srcdir)/widgets \
- -I$(top_builddir) \
- -I$(top_srcdir)/shell \
-I$(top_builddir)/shell \
-I$(top_srcdir)/widgets/misc \
-I$(top_srcdir)/addressbook/util \
-I$(top_srcdir)/addressbook/gui/contact-editor \
-I$(top_srcdir)/addressbook/gui/contact-list-editor \
-I$(top_srcdir)/addressbook/gui/widgets \
- -I$(top_builddir)/a11y/addressbook \
- -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -I$(top_srcdir)/a11y/addressbook \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
- -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
- -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\" \
- -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
-DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
-DPREFIX=\""$(prefix)"\" \
$(LDAP_CFLAGS) \
@@ -46,6 +40,7 @@ endif
libevolution_addressbook_la_LIBADD = \
$(SMIME_LIB) \
+ $(top_builddir)/e-util/libeutil.la \
$(top_builddir)/addressbook/printing/libecontactprint.la \
$(top_builddir)/shell/libeshell.la \
$(top_builddir)/addressbook/gui/merging/libeabbookmerging.la \
@@ -55,6 +50,8 @@ libevolution_addressbook_la_LIBADD = \
$(top_builddir)/addressbook/util/libeabutil.la \
$(top_builddir)/addressbook/gui/contact-editor/libecontacteditor.la \
$(top_builddir)/addressbook/gui/contact-list-editor/libecontactlisteditor.la \
+ $(top_builddir)/widgets/table/libetable.la \
+ $(top_builddir)/widgets/text/libetext.la \
$(top_builddir)/widgets/misc/libemiscwidgets.la \
$(top_builddir)/widgets/menus/libmenus.la \
$(top_builddir)/a11y/addressbook/libevolution-addressbook-a11y.la \
@@ -62,7 +59,7 @@ libevolution_addressbook_la_LIBADD = \
-libevolution_addressbook_la_LDFLAGS = -module -avoid-version
+libevolution_addressbook_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
# GConf schemas
@@ -74,12 +71,23 @@ schema_DATA = $(schema_in_files:.schemas.in.in=-$(BASE_VERSION).schemas)
@INTLTOOL_SCHEMAS_RULE@
+if OS_WIN32
+install-data-local:
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schema_DATA) ; do \
+ (echo set GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE); \
+ echo $(GCONFTOOL) --makefile-install-rule $$p) >_temp.bat; \
+ cmd /c _temp.bat; \
+ done \
+ fi
+else
install-data-local:
if test -z "$(DESTDIR)" ; then \
for p in $(schema_DATA) ; do \
GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p; \
done \
fi
+endif
server_in_files = GNOME_Evolution_Addressbook.server.in.in
server_DATA = $(server_in_files:.server.in.in=_$(BASE_VERSION).server)