aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2002-12-07 01:29:59 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2002-12-07 01:29:59 +0800
commit37751b5ece11dfa79a4175ec87f72670579d18ea (patch)
tree1d7d3b708990ef068e65a86c7c4250893b9b2577 /addressbook/gui/component/Makefile.am
parent1889b79a4a6d292c15b009d04be1f4147dc515dd (diff)
downloadgsoc2013-evolution-37751b5ece11dfa79a4175ec87f72670579d18ea.tar
gsoc2013-evolution-37751b5ece11dfa79a4175ec87f72670579d18ea.tar.gz
gsoc2013-evolution-37751b5ece11dfa79a4175ec87f72670579d18ea.tar.bz2
gsoc2013-evolution-37751b5ece11dfa79a4175ec87f72670579d18ea.tar.lz
gsoc2013-evolution-37751b5ece11dfa79a4175ec87f72670579d18ea.tar.xz
gsoc2013-evolution-37751b5ece11dfa79a4175ec87f72670579d18ea.tar.zst
gsoc2013-evolution-37751b5ece11dfa79a4175ec87f72670579d18ea.zip
#include <string.h>.
* gui/component/e-cardlist-model.c: #include <string.h>. * gui/component/addressbook-storage.c: #include <string.h>, <ctype.h>, <unistd.h>. * gui/component/addressbook-factory.c: Removed. * gui/component/addressbook-component.c: #include <bonobo/bonobo-main.h>, <unistd.h> and <string.h>. (create_view): addressbook_new_control() instead of addressbook_factory_new_control(). * gui/component/select-names/e-select-names.c (e_addressbook_create_ebook_table): Removed unused variable. (e_select_names_add_section): Removed unused variable. * gui/component/select-names/e-select-names-manager.c (focus_in_cb): Use g_source_remove() here instead of gtk_timeout_remove(). * gui/widgets/e-minicard-control.c (e_minicard_control_factory_init): Removed. (e_minicard_control_control_factory): Removed. (e_minicard_control_new): New. * gui/component/e-address-widget.c (e_address_widget_factory_init): Removed. (e_address_widget_new_control): Renamed from e_address_widget_factory_new_control(), made public. (e_address_widget_factory): Removed. * gui/component/e-address-popup.c (e_address_popup_new_control): New. (e_address_popup_factory_new_control): Removed. (e_address_popup_factory): Removed. (e_address_popup_factory_init): Removed. * gui/component/addressbook-config.c (addressbook_config_register_factory): Removed. (addressbook_config_create_control): New. * gui/component/addressbook-component.c (addressbook_component_factory_init): Removed. (addressbook_component_get_object): New. (owner_set_cb): Do not call addressbok_config_register_factory(). * gui/component/addressbook.c (addressbook_factory_init): Removed. (addressbook_new_control): Renamed from addressbook_factory_new_control(). svn path=/trunk/; revision=19041
Diffstat (limited to 'addressbook/gui/component/Makefile.am')
-rw-r--r--addressbook/gui/component/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/addressbook/gui/component/Makefile.am b/addressbook/gui/component/Makefile.am
index b5ec044cd5..f4e11047b5 100644
--- a/addressbook/gui/component/Makefile.am
+++ b/addressbook/gui/component/Makefile.am
@@ -27,19 +27,19 @@ INCLUDES = \
$(LDAP_CFLAGS) \
$(EVOLUTION_ADDRESSBOOK_CFLAGS)
-libexec_PROGRAMS = \
- evolution-addressbook
+componentdir = $(COMPONENT_DIR)
+component_LTLIBRARIES = libevolution-addressbook.la
-evolution_addressbook_SOURCES = \
+libevolution_addressbook_la_SOURCES = \
addressbook-component.c \
addressbook-component.h \
addressbook-config.c \
addressbook-config.h \
- addressbook-factory.c \
addressbook-storage.c \
addressbook-storage.h \
addressbook.c \
addressbook.h \
+ component-factory.c \
e-cardlist-model.c \
e-cardlist-model.h \
e-address-widget.h \
@@ -47,7 +47,7 @@ evolution_addressbook_SOURCES = \
e-address-popup.h \
e-address-popup.c
-evolution_addressbook_LDADD = \
+libevolution_addressbook_la_LIBADD = \
select-names/libeselectnames.la \
$(top_builddir)/shell/libeshell.la \
$(top_builddir)/addressbook/gui/widgets/libeminicard.a \
@@ -68,6 +68,9 @@ evolution_addressbook_LDADD = \
# not done yet:
# $(top_builddir)/filter/libfilter.la
+
+libevolution_addressbook_la_LDFLAGS = -module -avoid-version
+
# GConf schemas
schemadir = $(GCONF_SCHEMA_FILE_DIR)
@@ -85,7 +88,8 @@ server_in_files = GNOME_Evolution_Addressbook.server.in.in
serverdir = $(libdir)/bonobo/servers
server_DATA = $(server_in_files:.server.in.in=.server)
$(server_in_files:.server.in.in=.server.in): $(server_in_files)
- sed -e "s|\@LIBEXECDIR\@|$(libexecdir)|" $< > $@
+ sed -e "s|\@COMPONENTDIR\@|$(componentdir)|" $< > $@
+
@INTLTOOL_SERVER_RULE@
gladedir = $(datadir)/evolution/glade