aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/demo/Makefile.am
diff options
context:
space:
mode:
authorChristopher James Lahey <clahey@helixcode.com>2000-03-14 00:59:34 +0800
committerChris Lahey <clahey@src.gnome.org>2000-03-14 00:59:34 +0800
commitf59d7438e2498b9a7dcaf3d95e403069338ca0e2 (patch)
tree9c540a5ea870e15c44981b59d4e211d22b5cc356 /addressbook/demo/Makefile.am
parent2e19c1630acc12875081163e20ddd9538dafd741 (diff)
downloadgsoc2013-evolution-f59d7438e2498b9a7dcaf3d95e403069338ca0e2.tar
gsoc2013-evolution-f59d7438e2498b9a7dcaf3d95e403069338ca0e2.tar.gz
gsoc2013-evolution-f59d7438e2498b9a7dcaf3d95e403069338ca0e2.tar.bz2
gsoc2013-evolution-f59d7438e2498b9a7dcaf3d95e403069338ca0e2.tar.lz
gsoc2013-evolution-f59d7438e2498b9a7dcaf3d95e403069338ca0e2.tar.xz
gsoc2013-evolution-f59d7438e2498b9a7dcaf3d95e403069338ca0e2.tar.zst
gsoc2013-evolution-f59d7438e2498b9a7dcaf3d95e403069338ca0e2.zip
Added an E_FOLDER_CONTACTS section to the get_view function.
2000-03-13 Christopher James Lahey <clahey@helixcode.com> * shell/e-shell-view.c: Added an E_FOLDER_CONTACTS section to the get_view function. * addressbook/demo/Makefile.am: Added files for addressbook bonobo component. Changed non bonobo version to compile as test-addressbook. * addressbook/demo/addressbook.c, addressbook/demo/addressbook.gnorba, addressbook/demo/addressbook.h, addressbook/demo/addressbook-factory.c, addressbook/demo/addressbook-widget.c, addressbook/demo/addressbook-widget.h: New factory to create an addressbook bonobo component. svn path=/trunk/; revision=2114
Diffstat (limited to 'addressbook/demo/Makefile.am')
-rw-r--r--addressbook/demo/Makefile.am35
1 files changed, 33 insertions, 2 deletions
diff --git a/addressbook/demo/Makefile.am b/addressbook/demo/Makefile.am
index 27b438549c..4a7f39a503 100644
--- a/addressbook/demo/Makefile.am
+++ b/addressbook/demo/Makefile.am
@@ -5,21 +5,52 @@ INCLUDES = \
-I$(top_srcdir)/e-util \
-I$(top_srcdir)/widgets/e-table \
-I$(top_srcdir) \
- -I$(top_srcdir)/widgets/e-minicard
+ -I$(top_srcdir)/widgets/e-minicard \
+ $(BONOBO_HTML_GNOME_CFLAGS) \
+ -DEVOLUTION_VERSION=\""$(VERSION)"\" \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(datadir)/locale"\" \
+ -DCAMEL_PROVIDERDIR=\""$(providerdir)"\"
noinst_PROGRAMS = \
+ test-addressbook
+
+test_addressbook_SOURCES = \
+ demo.c \
+ e-test-model.c \
+ e-test-model.h
+
+test_addressbook_LDADD = \
+ $(EXTRA_GNOME_LIBS) \
+ $(top_builddir)/widgets/e-minicard/libeminicard.a \
+ $(top_builddir)/widgets/e-table/libetable.a \
+ $(top_builddir)/widgets/e-text/libetext.a \
+ $(top_builddir)/e-util/libeutil.la
+
+test_addressbook_LDFLAGS = `gnome-config --libs gdk_pixbuf`
+
+bin_PROGRAMS = \
evolution-addressbook
evolution_addressbook_SOURCES = \
- demo.c \
+ addressbook-factory.c \
+ addressbook-widget.c \
+ addressbook-widget.h \
+ addressbook.c \
+ addressbook.h \
e-test-model.c \
e-test-model.h
evolution_addressbook_LDADD = \
$(EXTRA_GNOME_LIBS) \
+ $(BONOBO_HTML_GNOME_LIBS) \
$(top_builddir)/widgets/e-minicard/libeminicard.a \
$(top_builddir)/widgets/e-table/libetable.a \
$(top_builddir)/widgets/e-text/libetext.a \
$(top_builddir)/e-util/libeutil.la
evolution_addressbook_LDFLAGS = `gnome-config --libs gdk_pixbuf`
+
+gnorbadir = $(sysconfdir)/CORBA/servers
+gnorba_DATA = addressbook.gnorba