aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/demo/Makefile.am
diff options
context:
space:
mode:
authorChristopher James Lahey <clahey@helixcode.com>2000-04-05 04:58:46 +0800
committerChris Lahey <clahey@src.gnome.org>2000-04-05 04:58:46 +0800
commitd8db781adee587ed1fc5b948a68d1d0a7c2952c2 (patch)
treee2003adb7f8e6dbf4ec917adf95c7f594113ce39 /addressbook/demo/Makefile.am
parent2d75a701029288c953a84ba0a696675f5a7eb77f (diff)
downloadgsoc2013-evolution-d8db781adee587ed1fc5b948a68d1d0a7c2952c2.tar
gsoc2013-evolution-d8db781adee587ed1fc5b948a68d1d0a7c2952c2.tar.gz
gsoc2013-evolution-d8db781adee587ed1fc5b948a68d1d0a7c2952c2.tar.bz2
gsoc2013-evolution-d8db781adee587ed1fc5b948a68d1d0a7c2952c2.tar.lz
gsoc2013-evolution-d8db781adee587ed1fc5b948a68d1d0a7c2952c2.tar.xz
gsoc2013-evolution-d8db781adee587ed1fc5b948a68d1d0a7c2952c2.tar.zst
gsoc2013-evolution-d8db781adee587ed1fc5b948a68d1d0a7c2952c2.zip
Changed this to backend to an ebook.
2000-04-04 Christopher James Lahey <clahey@helixcode.com> * addressbook/demo/e-test-model.c, addressbook/demo/e-test-model.h, addressbook/demo/Makefile.am: Changed this to backend to an ebook. * addressbook/backend/ebook/e-card-iterator.c, addressbook/backend/ebook/e-card-iterator.h, addressbook/backend/ebook/e-card-list-iterator.c, addressbook/backend/ebook/e-card-list.c, addressbook/backend/ebook/e-card-list.h, addressbook/backend/ebook/e-card.c, addressbook/backend/ebook/e-card.h: Fixed const correctness and changed a couple of functions to be external. * addressbook/Makefile.am: Fixed subdir ordering. svn path=/trunk/; revision=2287
Diffstat (limited to 'addressbook/demo/Makefile.am')
-rw-r--r--addressbook/demo/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/addressbook/demo/Makefile.am b/addressbook/demo/Makefile.am
index 4a7f39a503..84869488cc 100644
--- a/addressbook/demo/Makefile.am
+++ b/addressbook/demo/Makefile.am
@@ -6,6 +6,7 @@ INCLUDES = \
-I$(top_srcdir)/widgets/e-table \
-I$(top_srcdir) \
-I$(top_srcdir)/widgets/e-minicard \
+ -I$(top_srcdir)/addressbook/backend/ebook \
$(BONOBO_HTML_GNOME_CFLAGS) \
-DEVOLUTION_VERSION=\""$(VERSION)"\" \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
@@ -23,10 +24,13 @@ test_addressbook_SOURCES = \
test_addressbook_LDADD = \
$(EXTRA_GNOME_LIBS) \
+ $(BONOBO_HTML_GNOME_LIBS) \
$(top_builddir)/widgets/e-minicard/libeminicard.a \
$(top_builddir)/widgets/e-table/libetable.a \
$(top_builddir)/widgets/e-text/libetext.a \
- $(top_builddir)/e-util/libeutil.la
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/addressbook/backend/ebook/libebook.la \
+ $(top_builddir)/libversit/libversit.la
test_addressbook_LDFLAGS = `gnome-config --libs gdk_pixbuf`
@@ -43,12 +47,14 @@ evolution_addressbook_SOURCES = \
e-test-model.h
evolution_addressbook_LDADD = \
- $(EXTRA_GNOME_LIBS) \
+ $(EXTRA_GNOME_LIBS) \
$(BONOBO_HTML_GNOME_LIBS) \
$(top_builddir)/widgets/e-minicard/libeminicard.a \
$(top_builddir)/widgets/e-table/libetable.a \
$(top_builddir)/widgets/e-text/libetext.a \
- $(top_builddir)/e-util/libeutil.la
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/addressbook/backend/ebook/libebook.la \
+ $(top_builddir)/libversit/libversit.la
evolution_addressbook_LDFLAGS = `gnome-config --libs gdk_pixbuf`