aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/backend/pas/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2002-11-05 19:09:59 +0800
committerChris Toshok <toshok@src.gnome.org>2002-11-05 19:09:59 +0800
commit8e9511af0e47355211e189d5cba5dcd9ae97584c (patch)
treee85c07a8fa9537b996ee82b48ec3652247a82278 /addressbook/backend/pas/Makefile.am
parent02e66b1085341d95377d3f2173a1900102f20b9b (diff)
downloadgsoc2013-evolution-8e9511af0e47355211e189d5cba5dcd9ae97584c.tar
gsoc2013-evolution-8e9511af0e47355211e189d5cba5dcd9ae97584c.tar.gz
gsoc2013-evolution-8e9511af0e47355211e189d5cba5dcd9ae97584c.tar.bz2
gsoc2013-evolution-8e9511af0e47355211e189d5cba5dcd9ae97584c.tar.lz
gsoc2013-evolution-8e9511af0e47355211e189d5cba5dcd9ae97584c.tar.xz
gsoc2013-evolution-8e9511af0e47355211e189d5cba5dcd9ae97584c.tar.zst
gsoc2013-evolution-8e9511af0e47355211e189d5cba5dcd9ae97584c.zip
port to gnome 2.
2002-11-05 Chris Toshok <toshok@ximian.com> * backend/pas/pas-backend-card-sexp.[ch]: port to gnome 2. * backend/pas/pas-backend-file.[ch]: same. * backend/pas/pas-backend-file.[ch]: same. * backend/pas/pas-backend-ldap.[ch]: same. * backend/pas/pas-backend-summary.[ch]: same. * backend/pas/pas-backend.[ch]: same. * backend/pas/pas-book-factory.[ch]: same. * backend/pas/pas-book-view.[ch]: same. * backend/pas/pas-book.[ch]: same. * backend/pas/pas-card-cursor.[ch]: same. * backend/pas/pas-marshal.list: list of marshallers. * backend/pas/Makefile.am (libpas_a_SOURCES): add pas-marshal.c also add the marshal building foo. * backend/pas/.cvsignore: ignore pas-marshal.[ch] svn path=/trunk/; revision=18544
Diffstat (limited to 'addressbook/backend/pas/Makefile.am')
-rw-r--r--addressbook/backend/pas/Makefile.am25
1 files changed, 19 insertions, 6 deletions
diff --git a/addressbook/backend/pas/Makefile.am b/addressbook/backend/pas/Makefile.am
index eaaeebb25a..deac7eee14 100644
--- a/addressbook/backend/pas/Makefile.am
+++ b/addressbook/backend/pas/Makefile.am
@@ -10,10 +10,8 @@ CORBA_SOURCE = $(CORBA_SOURCE_H) $(CORBA_SOURCE_C)
idls = \
$(srcdir)/../idl/addressbook.idl
-idl_flags = `$(GNOME_CONFIG) --cflags idl` -I $(datadir)/idl
-
$(CORBA_SOURCE): $(idls)
- $(ORBIT_IDL) -I $(srcdir) $(srcdir)/../idl/addressbook.idl $(idl_flags)
+ $(ORBIT_IDL) $(IDL_INCLUDES) -I $(srcdir) $(srcdir)/../idl/addressbook.idl
INCLUDES = \
$(DB3_CFLAGS) \
@@ -65,7 +63,8 @@ libpas_a_SOURCES = \
pas-backend-file.c \
pas-backend.c \
pas-backend-summary.c \
- pas-card-cursor.c
+ pas-card-cursor.c \
+ pas-marshal.c
libpasfile_a_SOURCES = \
pas-backend-file.c \
@@ -76,10 +75,24 @@ libpasldap_a_SOURCES = \
$(LDAP_BACKEND_FILES)
endif
-BUILT_SOURCES = $(CORBA_SOURCE)
+# GLib marshalling cruft
+
+pas-marshal.h: pas-marshal.list
+ ( @GLIB_GENMARSHAL@ --prefix=pas_marshal pas-marshal.list --header > pas-marshal.tmp \
+ && mv pas-marshal.tmp pas-marshal.h ) \
+ || ( rm -f pas-marshal.tmp && exit 1 )
+
+pas-marshal.c: pas-marshal.h
+ ( @GLIB_GENMARSHAL@ --prefix=pas_marshal pas-marshal.list --body > pas-marshal.tmp \
+ && mv pas-marshal.tmp pas-marshal.c ) \
+ || ( rm -f pas-marshal.tmp && exit 1 )
+
+MARSHAL_GENERATED = pas-marshal.c pas-marshal.h
+
+BUILT_SOURCES = $(CORBA_SOURCE) $(MARSHAL_GENERATED)
CLEANFILES = $(BUILT_SOURCES)
dist-hook:
cd $(distdir); rm -f $(BUILT_SOURCES)
-EXTRA_DIST = $(LDAP_BACKEND_FILES) $(LDAP_SCHEMA)
+EXTRA_DIST = $(LDAP_BACKEND_FILES) $(LDAP_SCHEMA) pas-marshal.list