aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/backend/pas/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-04-21 07:18:51 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-04-21 07:18:51 +0800
commita2ee0e2ec91ae9dec0bd10cbc716651dfdf0932a (patch)
tree4aadfc1ee70b6d886decf95820964183181c215c /addressbook/backend/pas/Makefile.am
parente38b6187f5dbe154e07ec7b2d5fb036df0597265 (diff)
downloadgsoc2013-evolution-a2ee0e2ec91ae9dec0bd10cbc716651dfdf0932a.tar
gsoc2013-evolution-a2ee0e2ec91ae9dec0bd10cbc716651dfdf0932a.tar.gz
gsoc2013-evolution-a2ee0e2ec91ae9dec0bd10cbc716651dfdf0932a.tar.bz2
gsoc2013-evolution-a2ee0e2ec91ae9dec0bd10cbc716651dfdf0932a.tar.lz
gsoc2013-evolution-a2ee0e2ec91ae9dec0bd10cbc716651dfdf0932a.tar.xz
gsoc2013-evolution-a2ee0e2ec91ae9dec0bd10cbc716651dfdf0932a.tar.zst
gsoc2013-evolution-a2ee0e2ec91ae9dec0bd10cbc716651dfdf0932a.zip
Use "e-minicard" as the log domain.
2000-04-18 Federico Mena Quintero <federico@helixcode.com> * gui/minicard/Makefile.am (INCLUDES): Use "e-minicard" as the log domain. * gui/component/Makefile.am (INCLUDES): Use "evolution-addressbook" as the log domain. * backend/pas/Makefile.am: Build libpas.a, not a shared library. Do not install any header files. (INCLUDES): Remove spurious include paths. * backend/pas/*.[ch]: Fix includes. * backend/ebook/Makefile.am: Do not install the test programs. Fixed some include weirdness. * backend/ebook/*.[ch]: Fix includes. * contact-editor/Makefile.am (INCLUDES): Set the log domain to "contact-editor". (INCLUDES): Fix. * contact-editor/*.[ch]: Fix includes. * gui/minicard/*.[ch]: Fix includes. svn path=/trunk/; revision=2529
Diffstat (limited to 'addressbook/backend/pas/Makefile.am')
-rw-r--r--addressbook/backend/pas/Makefile.am41
1 files changed, 12 insertions, 29 deletions
diff --git a/addressbook/backend/pas/Makefile.am b/addressbook/backend/pas/Makefile.am
index c5f8ed302a..44cb5a66a1 100644
--- a/addressbook/backend/pas/Makefile.am
+++ b/addressbook/backend/pas/Makefile.am
@@ -1,7 +1,3 @@
-lib_LTLIBRARIES = libpas.la
-
-corbadir = $(sysconfdir)/CORBA/servers
-
CORBA_SOURCE = \
addressbook.h \
addressbook-common.c \
@@ -18,45 +14,32 @@ $(CORBA_SOURCE): $(idls)
INCLUDES = \
-DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
- -DG_LOG_DOMAIN=\"Wombat\" \
- -I$(builddir) \
- -I$(srcdir) -I$(top_srcdir) \
- -I$(srcdir)/. \
- -I$(srcdir)/.. \
- -I$(top_builddir) \
- -I$(includedir) \
- -I$(top_srcdir)/e-util \
- -I$(top_srcdir)/addressbook/backend/ebook \
+ -DG_LOG_DOMAIN=\"wombat-pas\" \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/addressbook/backend \
+ -I$(top_builddir)/addressbook/backend \
$(GNOME_INCLUDEDIR)
-gnome_libs = \
- $(GNOME_LIBDIR) \
- $(GNOMEUI_LIBS) \
- $(GNOMEGNORBA_LIBS) \
- $(INTLLIBS)
-
if ENABLE_LDAP
LDAP_BACKEND = pas-backend-ldap.c
endif
-libpas_la_SOURCES = \
+noinst_LIBRARIES = libpas.a
+
+libpas_a_SOURCES = \
$(CORBA_SOURCE) \
pas-book-factory.c \
+ pas-book-factory.h \
pas-book-view.c \
+ pas-book-view.h \
pas-book.c \
+ pas-book.h \
pas-backend-file.c \
+ pas-backend-file.h \
$(LDAP_BACKEND) \
pas-backend.c \
- pas-card-cursor.c
-
-libpasincludedir = $(includedir)/backend
-
-libpasinclude_HEADERS = \
- pas-book-factory.h \
- pas-book-view.h \
- pas-book.h \
- pas-backend-file.h \
pas-backend.h \
+ pas-card-cursor.c \
pas-card-cursor.h
BUILT_SOURCES = $(CORBA_SOURCE)