aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/backend/pas/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@src.gnome.org>2000-04-12 08:58:20 +0800
committerChris Toshok <toshok@src.gnome.org>2000-04-12 08:58:20 +0800
commitcce829e8a4730b293dc7fbd729b0b5775e48ba22 (patch)
tree4eae046a3d63dfd901976d2cc5b94ac0f50e0e7e /addressbook/backend/pas/Makefile.am
parentbed92671a3bbbd0264fa75d54779659922b81276 (diff)
downloadgsoc2013-evolution-cce829e8a4730b293dc7fbd729b0b5775e48ba22.tar
gsoc2013-evolution-cce829e8a4730b293dc7fbd729b0b5775e48ba22.tar.gz
gsoc2013-evolution-cce829e8a4730b293dc7fbd729b0b5775e48ba22.tar.bz2
gsoc2013-evolution-cce829e8a4730b293dc7fbd729b0b5775e48ba22.tar.lz
gsoc2013-evolution-cce829e8a4730b293dc7fbd729b0b5775e48ba22.tar.xz
gsoc2013-evolution-cce829e8a4730b293dc7fbd729b0b5775e48ba22.tar.zst
gsoc2013-evolution-cce829e8a4730b293dc7fbd729b0b5775e48ba22.zip
add LDAP_LIBS here.
* wombat/Makefile.am (wombat_LDADD): add LDAP_LIBS here. * configure.in: check for -lldap and -llber and if both are present include ldap support in the pas/wombat. * addressbook/backend/pas/Makefile.am (libpas_la_SOURCES): include pas-backend.ldap.c if ENABLE_LDAP. * addressbook/backend/pas/pas-backend-ldap.c: get searching working (converting between the sexp and ldap stuff.) * wombat/wombat.c (setup_pas): register the ldap pas backend if HAVE_LDAP is defined. svn path=/trunk/; revision=2401
Diffstat (limited to 'addressbook/backend/pas/Makefile.am')
-rw-r--r--addressbook/backend/pas/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/addressbook/backend/pas/Makefile.am b/addressbook/backend/pas/Makefile.am
index dc2c4b5beb..dfaf7aae54 100644
--- a/addressbook/backend/pas/Makefile.am
+++ b/addressbook/backend/pas/Makefile.am
@@ -34,12 +34,17 @@ gnome_libs = \
$(GNOMEGNORBA_LIBS) \
$(INTLLIBS)
+if ENABLE_LDAP
+LDAP_BACKEND = pas-backend-ldap.c
+endif
+
libpas_la_SOURCES = \
$(CORBA_SOURCE) \
pas-book-factory.c \
pas-book-view.c \
pas-book.c \
pas-backend-file.c \
+ $(LDAP_BACKEND) \
pas-backend.c \
pas-card-cursor.c