aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/backend/ebook/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2001-10-13 05:00:13 +0800
committerChris Toshok <toshok@src.gnome.org>2001-10-13 05:00:13 +0800
commitc60e4c4a61f7b285601e707888bd8c4a1d29cd51 (patch)
tree7ebeab524a59bc62583ea21df4aaf73f1a2d10f7 /addressbook/backend/ebook/Makefile.am
parentfdd4274ddfa0df8cb700be79f7a13b6e514d20e9 (diff)
downloadgsoc2013-evolution-c60e4c4a61f7b285601e707888bd8c4a1d29cd51.tar
gsoc2013-evolution-c60e4c4a61f7b285601e707888bd8c4a1d29cd51.tar.gz
gsoc2013-evolution-c60e4c4a61f7b285601e707888bd8c4a1d29cd51.tar.bz2
gsoc2013-evolution-c60e4c4a61f7b285601e707888bd8c4a1d29cd51.tar.lz
gsoc2013-evolution-c60e4c4a61f7b285601e707888bd8c4a1d29cd51.tar.xz
gsoc2013-evolution-c60e4c4a61f7b285601e707888bd8c4a1d29cd51.tar.zst
gsoc2013-evolution-c60e4c4a61f7b285601e707888bd8c4a1d29cd51.zip
commit the importer originally from Michael M. Morrison, with fixups by
2001-10-12 Chris Toshok <toshok@ximian.com> * backend/ebook/evolution-ldif-importer.c: commit the importer originally from Michael M. Morrison, with fixups by toshok. * backend/ebook/Makefile.am (bin_PROGRAMS): add evolution-ldif-importer. (oaf_in_files): add GNOME_Evolution_Addressbook_LDIF_Importer.oaf.in. * backend/ebook/e-card-simple.h: add WANTS_HTML and IS_LIST. * backend/ebook/e-card-simple.c (field_data): add WANTS_HTML and IS_LIST. (e_card_simple_set): fix typo. * backend/ebook/.cvsignore: ignore GNOME_Evolution_Addressbook_LDIF_Importer.oaf and evolution-ldif-importer. * backend/ebook/GNOME_Evolution_Addressbook_LDIF_Importer.oaf.in: ldif importer oafinfo. svn path=/trunk/; revision=13627
Diffstat (limited to 'addressbook/backend/ebook/Makefile.am')
-rw-r--r--addressbook/backend/ebook/Makefile.am24
1 files changed, 21 insertions, 3 deletions
diff --git a/addressbook/backend/ebook/Makefile.am b/addressbook/backend/ebook/Makefile.am
index c2bcbe7c75..ea49ad47f3 100644
--- a/addressbook/backend/ebook/Makefile.am
+++ b/addressbook/backend/ebook/Makefile.am
@@ -1,7 +1,9 @@
noinst_PROGRAMS = test-card test-client test-client-list
-bin_PROGRAMS = evolution-vcard-importer \
- load-pine-addressbook load-gnomecard-addressbook
+bin_PROGRAMS = evolution-vcard-importer \
+ evolution-ldif-importer \
+ load-pine-addressbook \
+ load-gnomecard-addressbook
CORBA_SOURCE = \
addressbook.h \
@@ -133,6 +135,21 @@ evolution_vcard_importer_LDADD = \
$(top_builddir)/libversit/libversit.la \
$(top_builddir)/e-util/libeutil.la
+evolution_ldif_importer_SOURCES = \
+ evolution-ldif-importer.c
+evolution_ldif_importer_LDADD = \
+ libebook.la \
+ $(BONOBO_CONF_LIBS) \
+ $(BONOBO_GNOME_LIBS) \
+ $(EXTRA_GNOME_LIBS) \
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/libibex/libibex.la \
+ $(top_builddir)/shell/importer/libevolution-importer.la \
+ $(DB3_LDADD) \
+ $(top_builddir)/e-util/ename/libename.la \
+ $(top_builddir)/libversit/libversit.la \
+ $(top_builddir)/e-util/libeutil.la
+
load_pine_addressbook_SOURCES = \
load-pine-addressbook.c
@@ -170,7 +187,8 @@ dist-hook:
cd $(distdir); rm -f $(BUILT_SOURCES)
oafdir = $(datadir)/oaf
-oaf_in_files = GNOME_Evolution_Addressbook_VCard_Importer.oaf.in
+oaf_in_files = GNOME_Evolution_Addressbook_VCard_Importer.oaf.in \
+ GNOME_Evolution_Addressbook_LDIF_Importer.oaf.in
oaf_DATA = $(oaf_in_files:.oaf.in=.oaf)
@XML_I18N_MERGE_OAF_RULE@