aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/backend/ebook/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2003-03-01 02:02:35 +0800
committerDan Winship <danw@src.gnome.org>2003-03-01 02:02:35 +0800
commit5597bf794e72cd92935a7ac9828bcb590fcbb853 (patch)
tree8c4a461a70977e4de82433c90d0baa173db38b60 /addressbook/backend/ebook/Makefile.am
parent4ab6d9ca9b4695fc7bd9358db93cac9a5f78df6c (diff)
downloadgsoc2013-evolution-5597bf794e72cd92935a7ac9828bcb590fcbb853.tar
gsoc2013-evolution-5597bf794e72cd92935a7ac9828bcb590fcbb853.tar.gz
gsoc2013-evolution-5597bf794e72cd92935a7ac9828bcb590fcbb853.tar.bz2
gsoc2013-evolution-5597bf794e72cd92935a7ac9828bcb590fcbb853.tar.lz
gsoc2013-evolution-5597bf794e72cd92935a7ac9828bcb590fcbb853.tar.xz
gsoc2013-evolution-5597bf794e72cd92935a7ac9828bcb590fcbb853.tar.zst
gsoc2013-evolution-5597bf794e72cd92935a7ac9828bcb590fcbb853.zip
Remove these from here; talking to the mailer doesn't really belong at the
* backend/ebook/e-card.c (e_card_list_send, e_card_send): Remove these from here; talking to the mailer doesn't really belong at the libebook level anyway. * backend/ebook/Makefile.am: Remove Evolution-Composer CORBA stuff, which fixes some linking problems on OS X. * gui/widgets/e-addressbook-util.c (e_addressbook_send_card_list, e_addressbook_send_card): Move from e-card.c and rename. * gui/widgets/Makefile.am: move Evolution-Composer CORBA stuff here * gui/widgets/e-addressbook-view.c (send_as, send_to, e_addressbook_view_send, e_addressbook_view_send_to): Update for new function names. * gui/contact-list-editor/e-contact-list-editor.c (file_send_as_cb, file_send_to_cb): Likewise * gui/contact-editor/e-contact-editor.c (file_send_as_cb, file_send_to_cb): Likewise svn path=/trunk/; revision=20103
Diffstat (limited to 'addressbook/backend/ebook/Makefile.am')
-rw-r--r--addressbook/backend/ebook/Makefile.am20
1 files changed, 3 insertions, 17 deletions
diff --git a/addressbook/backend/ebook/Makefile.am b/addressbook/backend/ebook/Makefile.am
index 955b7b7e81..3dc8c177c4 100644
--- a/addressbook/backend/ebook/Makefile.am
+++ b/addressbook/backend/ebook/Makefile.am
@@ -24,24 +24,10 @@ $(CORBA_ADDRESSBOOK_SOURCE_H): $(CORBA_ADDRESSBOOK_IDL)
$(CORBA_ADDRESSBOOK_SOURCE_C): $(CORBA_ADDRESSBOOK_SOURCE_H)
-
-CORBA_COMPOSER_SOURCE_H = \
- Evolution-Composer.h
-CORBA_COMPOSER_SOURCE_C = \
- Evolution-Composer-common.c \
- Evolution-Composer-skels.c \
- Evolution-Composer-stubs.c
-CORBA_COMPOSER_IDL = $(srcdir)/../../../composer/Evolution-Composer.idl
-
-CORBA_SOURCE_H = $(CORBA_COMPOSER_SOURCE_H) $(CORBA_ADDRESSBOOK_SOURCE_H)
-CORBA_SOURCE_C = $(CORBA_COMPOSER_SOURCE_C) $(CORBA_ADDRESSBOOK_SOURCE_C)
+CORBA_SOURCE_H = $(CORBA_ADDRESSBOOK_SOURCE_H)
+CORBA_SOURCE_C = $(CORBA_ADDRESSBOOK_SOURCE_C)
CORBA_SOURCE = $(CORBA_SOURCE_H) $(CORBA_SOURCE_C)
-$(CORBA_COMPOSER_SOURCE_H): $(CORBA_COMPOSER_IDL)
- $(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) $(CORBA_COMPOSER_IDL)
-
-$(CORBA_COMPOSER_SOURCE_C): $(CORBA_COMPOSER_SOURCE_H)
-
# The component
@@ -185,7 +171,7 @@ BUILT_SOURCES = $(CORBA_SOURCE) $(MARSHAL_GENERATED)
CLEANFILES = $(BUILT_SOURCES)
dist-hook:
- cd $(distdir); rm -f $(BUILT_SOURCES) $(CORBA_SOURCE_C)
+ cd $(distdir); rm -f $(BUILT_SOURCES)
server_in_files = GNOME_Evolution_Addressbook_VCard_Importer.server.in.in \
GNOME_Evolution_Addressbook_LDIF_Importer.server.in.in