aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/backend/ebook/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2003-02-06 07:46:49 +0800
committerDan Winship <danw@src.gnome.org>2003-02-06 07:46:49 +0800
commit4958846621bc7287ea3cca53aa6f060c6d1c294e (patch)
treef3f255e4a8affd6b5ae6b62b68151d4fd25c267f /addressbook/backend/ebook/Makefile.am
parente40fc549356925a206c3cd6ea4b0c0e352c26c07 (diff)
downloadgsoc2013-evolution-4958846621bc7287ea3cca53aa6f060c6d1c294e.tar
gsoc2013-evolution-4958846621bc7287ea3cca53aa6f060c6d1c294e.tar.gz
gsoc2013-evolution-4958846621bc7287ea3cca53aa6f060c6d1c294e.tar.bz2
gsoc2013-evolution-4958846621bc7287ea3cca53aa6f060c6d1c294e.tar.lz
gsoc2013-evolution-4958846621bc7287ea3cca53aa6f060c6d1c294e.tar.xz
gsoc2013-evolution-4958846621bc7287ea3cca53aa6f060c6d1c294e.tar.zst
gsoc2013-evolution-4958846621bc7287ea3cca53aa6f060c6d1c294e.zip
Remove cruft. (libebookincludedir): Use privincludedir.
* backend/ebook/Makefile.am (INCLUDES): Remove cruft. (libebookincludedir): Use privincludedir. * backend/ebook/e-book-util.c: #include <string.h> * backend/ebook/e-card-compare.c: Likewise * backend/ebook/load-pine-addressbook.c: Likewise * backend/ebook/test-client.c: Likewise * backend/ebook/evolution-vcard-importer.c: #include <e-book-util.h> (factory_fn): Fix this to actually return the importer. * backend/ebook/evolution-ldif-importer.c (parseLine): #include <e-book-util.h> and <bonobo/bonobo-main.h>. Use g_ascii_strcmp. * backend/ebook/e-card.c (e_card_email_match_single_string): (e_card_email_find_number): s/g_str/g_ascii_str/ * backend/ebook/e-destination.c (e_destination_equal): Likewise. Also, add an "else return FALSE;" svn path=/trunk/; revision=19778
Diffstat (limited to 'addressbook/backend/ebook/Makefile.am')
-rw-r--r--addressbook/backend/ebook/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/addressbook/backend/ebook/Makefile.am b/addressbook/backend/ebook/Makefile.am
index 450c1d052f..772342041d 100644
--- a/addressbook/backend/ebook/Makefile.am
+++ b/addressbook/backend/ebook/Makefile.am
@@ -27,7 +27,6 @@ INCLUDES = \
-DSYSCONFDIR=\"$(sysconfdir)\" \
-DDATADIR=\"$(datadir)\" \
-DLIBDIR=\"$(libdir)\" \
- -DGNOMELOCALEDIR=\""$(localedir)"\" \
-DG_LOG_DOMAIN=\"EBook\" \
-I$(top_srcdir) \
-I$(top_srcdir)/camel \
@@ -58,7 +57,7 @@ libebook_la_SOURCES = \
e-destination.c
-libebookincludedir = $(includedir)/evolution-$(BASE_VERSION)/ebook
+libebookincludedir = $(privincludedir)/ebook
libebookinclude_HEADERS = \
e-book-listener.h \
@@ -184,11 +183,10 @@ CLEANFILES = $(BUILT_SOURCES)
dist-hook:
cd $(distdir); rm -f $(BUILT_SOURCES)
-serversdir = $(libdir)/bonobo/servers
server_in_files = GNOME_Evolution_Addressbook_VCard_Importer.server.in \
GNOME_Evolution_Addressbook_LDIF_Importer.server.in
-servers_DATA = $(server_in_files:.server.in=.server)
+server_DATA = $(server_in_files:.server.in=.server)
@INTLTOOL_SERVER_RULE@
-EXTRA_DIST = $(server_in_files) $(servers_DATA) e-book-marshal.list
+EXTRA_DIST = $(server_in_files) $(server_DATA) e-book-marshal.list