aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/backend/ebook/Makefile.am
diff options
context:
space:
mode:
authorJon Trowbridge <trow@ximian.com>2001-02-20 06:49:18 +0800
committerJon Trowbridge <trow@src.gnome.org>2001-02-20 06:49:18 +0800
commitd369e177b199c4c798f0b6ad8972951d8586bcd9 (patch)
tree492dd3459df5e78e6709e7879a70011f4f729012 /addressbook/backend/ebook/Makefile.am
parent54105acd4e5283899c1659e64e41341eec8d667c (diff)
downloadgsoc2013-evolution-d369e177b199c4c798f0b6ad8972951d8586bcd9.tar
gsoc2013-evolution-d369e177b199c4c798f0b6ad8972951d8586bcd9.tar.gz
gsoc2013-evolution-d369e177b199c4c798f0b6ad8972951d8586bcd9.tar.bz2
gsoc2013-evolution-d369e177b199c4c798f0b6ad8972951d8586bcd9.tar.lz
gsoc2013-evolution-d369e177b199c4c798f0b6ad8972951d8586bcd9.tar.xz
gsoc2013-evolution-d369e177b199c4c798f0b6ad8972951d8586bcd9.tar.zst
gsoc2013-evolution-d369e177b199c4c798f0b6ad8972951d8586bcd9.zip
When creating the entry, open up an ebook (corresponding to the local
2001-02-19 Jon Trowbridge <trow@ximian.com> * gui/component/select-names/e-select-names-manager.c (e_select_names_manager_create_entry): When creating the entry, open up an ebook (corresponding to the local addressbook) and make the entry use an EAddressCompletion. (completion_handler): Added; this is the actual completion handler, which manipulates the entry when the user selects something from the drop-down. * gui/component/select-names/e-select-names-model.c: Various hacks by clahey to unbreak e_select_names_model_add_item, e_select_names_model_replace_item (which I added) and e_select_names_model_remove_item. * gui/component/select-names/e-select-names-text-model.c (e_select_names_text_model_obj_count, e_select_names_text_model_get_nth_obj): Make chunks of text that correspond to ECards in the ESelectNamesModel be embedded objects. (e_select_names_text_model_activate_obj): On activation, pop up a contact editor for the embedded object's card. (e_select_names_text_model_model_changed): Fixed to work with ETextModel API changes. (e_select_names_text_model_set_text): Make const correct. (e_select_names_text_model_insert): Make const correct. (e_select_names_text_model_insert_length): Make const correct. * backend/ebook/e-address-completion.h, backend/ebook/e-address-completion.c: Added. EAddressCompletion is a derived class of ECompletion that does asynchronous address lookups for completions. svn path=/trunk/; revision=8282
Diffstat (limited to 'addressbook/backend/ebook/Makefile.am')
-rw-r--r--addressbook/backend/ebook/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/addressbook/backend/ebook/Makefile.am b/addressbook/backend/ebook/Makefile.am
index 335f74cb4c..0072ef8820 100644
--- a/addressbook/backend/ebook/Makefile.am
+++ b/addressbook/backend/ebook/Makefile.am
@@ -1,4 +1,4 @@
-noinst_PROGRAMS = test-card test-client test-client-list
+noinst_PROGRAMS = test-card test-client test-client-list test-completion
bin_PROGRAMS = evolution-gnomecard-importer \
load-pine-addressbook load-gnomecard-addressbook
@@ -39,6 +39,7 @@ lib_LTLIBRARIES = libebook.la
libebook_la_SOURCES = \
$(CORBA_SOURCE) \
+ e-address-completion.c \
e-book-listener.c \
e-book-view-listener.c \
e-book-view.c \
@@ -50,6 +51,7 @@ libebook_la_SOURCES = \
libebookincludedir = $(includedir)/evolution/ebook
libebookinclude_HEADERS = \
+ e-address-completion.h \
e-book-listener.h \
e-book-types.h \
e-book-view-listener.h \
@@ -103,6 +105,17 @@ test_card_LDADD = \
$(top_builddir)/libversit/libversit.la \
$(top_builddir)/e-util/libeutil.la
+test_completion_SOURCES = \
+ test-completion.c
+
+test_completion_LDADD = \
+ libebook.la \
+ $(BONOBO_GNOME_LIBS) \
+ $(EXTRA_GNOME_LIBS) \
+ $(top_builddir)/e-util/ename/libename.la \
+ $(top_builddir)/libversit/libversit.la \
+ $(top_builddir)/e-util/libeutil.la
+
evolution_gnomecard_importer_SOURCES = \
evolution-gnomecard-importer.c
evolution_gnomecard_importer_LDADD = \
@@ -151,3 +164,7 @@ oaf_DATA = $(oaf_in_files:.oaf.in=.oaf)
# GNOME_Evolution_Addressbook_Pine_Importer.oafinfo
EXTRA_DIST = $(oaf_in_files) $(oaf_DATA)
+
+
+
+