aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/Makefile.am
diff options
context:
space:
mode:
authorMatthew Loper <mloper@src.gnome.org>2000-04-10 02:33:50 +0800
committerMatthew Loper <mloper@src.gnome.org>2000-04-10 02:33:50 +0800
commit99612fe24cfc0dcb5bc8f020fe759ccb3cfc1416 (patch)
tree1d9cbc180c215df2f66f0786f8c1180415934128 /addressbook/Makefile.am
parent01bf08bdbc72d2183d40aa88b503b07bea8fff11 (diff)
downloadgsoc2013-evolution-99612fe24cfc0dcb5bc8f020fe759ccb3cfc1416.tar
gsoc2013-evolution-99612fe24cfc0dcb5bc8f020fe759ccb3cfc1416.tar.gz
gsoc2013-evolution-99612fe24cfc0dcb5bc8f020fe759ccb3cfc1416.tar.bz2
gsoc2013-evolution-99612fe24cfc0dcb5bc8f020fe759ccb3cfc1416.tar.lz
gsoc2013-evolution-99612fe24cfc0dcb5bc8f020fe759ccb3cfc1416.tar.xz
gsoc2013-evolution-99612fe24cfc0dcb5bc8f020fe759ccb3cfc1416.tar.zst
gsoc2013-evolution-99612fe24cfc0dcb5bc8f020fe759ccb3cfc1416.zip
+ * addressbook/Makefile.am: Compile contact-editor, _then_ gui,
+ since the gui now depends on the contact editor (shouldn't the + contact-editor directory be moved into 'gui'?). + + * addressbook/gui/component/addressbook.c (card_added_cb): New + function. Gets called when a card is successfully added via the + contact-editor. + (new_contact_cb): New function. Gets called when a user clicks the + "new contact" button on the toolbar, and creates a contact-editor + to edit a new contact entry. + (control_activate): Call gnome_app_fill_toolbar_with_data() + instead of gnome_app_fill_toolbar(), so that our toolbar can find + the right book to add a new card to. + (addressbook_factory): On an "activate" signal, send the book up + to control_activate_cb. + + * addressbook/gui/component/addressbook-factory.c (init_bonobo): + Call glade_gnome_init(), so that our contact-editor (which + requires glade) doesn't barf. + + * addressbook/gui/component/Makefile.am: added the contact-editor + to our libraries and include files. + + * addressbook/contact-editor/e-contact-editor.c + (e_contact_editor_new): Set "card" gtk property to the passed-in + card property. svn path=/trunk/; revision=2351
Diffstat (limited to 'addressbook/Makefile.am')
-rw-r--r--addressbook/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/addressbook/Makefile.am b/addressbook/Makefile.am
index b5d6387af6..22f0922618 100644
--- a/addressbook/Makefile.am
+++ b/addressbook/Makefile.am
@@ -1,2 +1,2 @@
SUBDIRS = \
- backend gui contact-editor printing
+ backend contact-editor gui printing