aboutsummaryrefslogtreecommitdiffstats
path: root/a11y/calendar/Makefile.am
diff options
context:
space:
mode:
authorBolian Yin <bolian.yin@sun.com>2003-08-27 11:36:42 +0800
committerBolian Yin <byin@src.gnome.org>2003-08-27 11:36:42 +0800
commite8fc140c7030594e556b56242afd2b52abc61634 (patch)
tree876546f299eef99a70b4c31868d83f6a903604bd /a11y/calendar/Makefile.am
parent7e3eb5f87d84f5c7e7c945bb971367861928a9a0 (diff)
downloadgsoc2013-evolution-e8fc140c7030594e556b56242afd2b52abc61634.tar
gsoc2013-evolution-e8fc140c7030594e556b56242afd2b52abc61634.tar.gz
gsoc2013-evolution-e8fc140c7030594e556b56242afd2b52abc61634.tar.bz2
gsoc2013-evolution-e8fc140c7030594e556b56242afd2b52abc61634.tar.lz
gsoc2013-evolution-e8fc140c7030594e556b56242afd2b52abc61634.tar.xz
gsoc2013-evolution-e8fc140c7030594e556b56242afd2b52abc61634.tar.zst
gsoc2013-evolution-e8fc140c7030594e556b56242afd2b52abc61634.zip
add widgets directory; move calendar idl stuff to calendar directory; stop
2003-08-27 Bolian Yin <bolian.yin@sun.com> * Makefile.am: add widgets directory; move calendar idl stuff to calendar directory; stop make a single shared lib for whole a11y stuff. * ea-factory.h: make factory macros available to GOBJECT * calendar/Makefile.am: add calendar idl stuff * calendar/ea-cal-view-event.c: add atkcomponent interface. * calendar/ea-gnome-calendar.c (ea_gcal_switch_view_cb): add details for "children_changed". * new widgets directory for widgets a11y stuff, new files are: widgets/Makefile.am, widgets/ea-calendar-item.c, widgets/ea-calendar-item.h, widgets/ea-widgets.c, widgets/ea-widgets.h svn path=/trunk/; revision=22384
Diffstat (limited to 'a11y/calendar/Makefile.am')
-rw-r--r--a11y/calendar/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/a11y/calendar/Makefile.am b/a11y/calendar/Makefile.am
index 849e152135..2c3a26f2ba 100644
--- a/a11y/calendar/Makefile.am
+++ b/a11y/calendar/Makefile.am
@@ -1,4 +1,46 @@
+# Calendar IDL files
+
+CALENDAR_IDLS = $(top_srcdir)/calendar/idl/evolution-calendar.idl
+SHELL_IDLS = \
+ $(top_srcdir)/shell/Evolution-Activity.idl \
+ $(top_srcdir)/shell/Evolution-ConfigControl.idl \
+ $(top_srcdir)/shell/Evolution-Offline.idl \
+ $(top_srcdir)/shell/Evolution-Session.idl \
+ $(top_srcdir)/shell/Evolution-Shell.idl \
+ $(top_srcdir)/shell/Evolution-ShellComponent.idl \
+ $(top_srcdir)/shell/Evolution-ShellComponentDnd.idl \
+ $(top_srcdir)/shell/Evolution-ShellView.idl \
+ $(top_srcdir)/shell/Evolution-Shortcuts.idl \
+ $(top_srcdir)/shell/Evolution-Storage.idl \
+ $(top_srcdir)/shell/Evolution-StorageSetView.idl \
+ $(top_srcdir)/shell/Evolution-Wizard.idl \
+ $(top_srcdir)/shell/Evolution-common.idl \
+ $(top_srcdir)/shell/Evolution.idl
+
+CALENDAR_IDL_GENERATED_H = evolution-calendar.h
+CALENDAR_IDL_GENERATED_C = \
+ evolution-calendar-common.c \
+ evolution-calendar-skels.c \
+ evolution-calendar-stubs.c
+SHELL_IDL_GENERATED_H = Evolution.h
+SHELL_IDL_GENERATED_C = \
+ Evolution-common.c \
+ Evolution-skels.c \
+ Evolution-stubs.c
+
+$(CALENDAR_IDL_GENERATED_H): $(CALENDAR_IDLS)
+ $(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) \
+ $(top_srcdir)/calendar/idl/evolution-calendar.idl
+
+$(SHELL_IDL_GENERATED_H): $(SHELL_IDLS)
+ $(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) \
+ $(top_srcdir)/shell/Evolution.idl
+
+IDL_GENERATED = $(SHELL_IDL_GENERATED_H) $(CALENDAR_IDL_GENERATED_H)
+BUILT_SOURCES = $(IDL_GENERATED)
+CLEANFILES = $(BUILT_SOURCES) $(CALENDAR_IDL_GENERATED_C) $(SHELL_IDL_GENERATED_C)
+
noinst_LTLIBRARIES = libevolution-calendar-a11y.la
INCLUDES = \
@@ -22,6 +64,8 @@ INCLUDES = \
$(EVOLUTION_CALENDAR_CFLAGS)
libevolution_calendar_a11y_la_SOURCES = \
+ $(CALENDAR_IDL_GENERATED_H) \
+ $(SHELL_IDL_GENERATED_H) \
ea-calendar.c \
ea-calendar.h \
ea-calendar-helpers.c \