aboutsummaryrefslogtreecommitdiffstats
path: root/a11y/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-06-18 19:05:17 +0800
committerTor Lillqvist <tml@src.gnome.org>2005-06-18 19:05:17 +0800
commit1277e030c205ea8db370ef4e9fd3db08f422763c (patch)
tree3cf15130deee4f75afc39072ba940fff5d233368 /a11y/Makefile.am
parent0f6df5b91d5248204f2837f6de035bb3ca70686e (diff)
downloadgsoc2013-evolution-1277e030c205ea8db370ef4e9fd3db08f422763c.tar
gsoc2013-evolution-1277e030c205ea8db370ef4e9fd3db08f422763c.tar.gz
gsoc2013-evolution-1277e030c205ea8db370ef4e9fd3db08f422763c.tar.bz2
gsoc2013-evolution-1277e030c205ea8db370ef4e9fd3db08f422763c.tar.lz
gsoc2013-evolution-1277e030c205ea8db370ef4e9fd3db08f422763c.tar.xz
gsoc2013-evolution-1277e030c205ea8db370ef4e9fd3db08f422763c.tar.zst
gsoc2013-evolution-1277e030c205ea8db370ef4e9fd3db08f422763c.zip
Makefile.am addressbook/Makefile.am calendar/Makefile.am Use the fake
2005-06-18 Tor Lillqvist <tml@novell.com> * Makefile.am * addressbook/Makefile.am * calendar/Makefile.am * widgets/Makefile.am: Use the fake "bootstrap" libraries on Win32 to get around circular dependencies. Use NO_UNDEFINED. * Makefile.am: No need to pass -I pointing to this directory itself, all inclusions of headers from here are with doublequotes. Link with libeutil. No need to link with REGEX_LIBS. * addressbook/Makefile.am * calendar/Makefile.am * widgets/Makefile.am: Prune out superfluous -I options and -D options for EVOLUTION_* pathname macros that aren't used in the source files in that directory. * addressbook/Makefile.am: Drop A11Y_CFLAGS, its a subset of EVOLUTION_ADDRESSBOOK_CFLAGS anyway. Link with EVOLUTION_ADDRESSBOOK_LIBS. * a11y/addressbook/ea-addressbook.c: Include headers from the same directory as such. * calendar/Makefile.am: Drop A11Y_CFLAGS, its a subset of EVOLUTION_CALENDAR_CFLAGS anyway. Link with EVOLUTION_CALENDAR_LIBS. * e-table/Makefile.am (INCLUDES) * e-text/Makefile.am (INCLUDES): Drop the undefined GNOME_BONOBO_CFLAGS and GNOME_INCLUDEDIR. Drop GNOME_FULL_CFLAGS, it's a subset of EXTRA_GNOME_CFLAGS. * widgets/Makefile.am: E_WIDGETS_CFLAGS is enough. No need for EVOLUTION_CALENDAR_CFLAGS, which . Link with E_WIDGET_LIBS. Drop A11Y_CFLAGS, subset of E_WIDGET_CFLAGS. svn path=/trunk/; revision=29533
Diffstat (limited to 'a11y/Makefile.am')
-rw-r--r--a11y/Makefile.am22
1 files changed, 16 insertions, 6 deletions
diff --git a/a11y/Makefile.am b/a11y/Makefile.am
index 96a9014b70..960287aa70 100644
--- a/a11y/Makefile.am
+++ b/a11y/Makefile.am
@@ -1,12 +1,19 @@
+# Somewhat odd looking to have "." in SUBDIRS, but apparently it works?
SUBDIRS = e-text e-table . calendar widgets addressbook
+if OS_WIN32
+WIN32_BOOTSTRAP_LIBS = \
+ $(top_builddir)/win32/libemiscwidgets.la \
+ $(top_builddir)/win32/libetable.la \
+ $(top_builddir)/win32/libetext.la
+endif
+
# for debug
#A11Y_CFLAGS += -pedantic -ansi -DACC_DEBUG -Werror
privlib_LTLIBRARIES = libevolution-a11y.la
INCLUDES = \
- -I$(top_srcdir)/a11y \
$(A11Y_CFLAGS)
libevolution_a11y_la_SOURCES = \
@@ -21,8 +28,11 @@ libevolution_a11yinclude_HEADERS = \
gal-a11y-util.h \
gal-a11y-factory.h
-libevolution_a11y_la_LIBADD = \
- e-text/libgal-a11y-etext.la \
- e-table/libgal-a11y-etable.la \
- $(EXTRA_GNOME_LIBS) \
- $(REGEX_LIBS)
+libevolution_a11y_la_LDFLAGS = $(NO_UNDEFINED)
+
+libevolution_a11y_la_LIBADD = \
+ $(WIN32_BOOTSTRAP_LIBS) \
+ e-text/libgal-a11y-etext.la \
+ e-table/libgal-a11y-etable.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(EXTRA_GNOME_LIBS)