aboutsummaryrefslogtreecommitdiffstats
path: root/src/bookmarks/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/bookmarks/Makefile.am')
-rw-r--r--src/bookmarks/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/bookmarks/Makefile.am b/src/bookmarks/Makefile.am
index aceaeef13..bf87823dd 100644
--- a/src/bookmarks/Makefile.am
+++ b/src/bookmarks/Makefile.am
@@ -66,6 +66,7 @@ ephy-bookmarks-type-builtins.c: stamp-ephy-bookmarks-type-builtins.c Makefile
@true
stamp-ephy-bookmarks-type-builtins.c: Makefile $(INST_H_FILES) $(NOINST_H_FILES)
$(GLIB_MKENUMS) \
+ --fhead "#include <config.h>\n\n" \
--fhead "#include \"ephy-bookmarks-type-builtins.h\"\n\n" \
--fprod "\n/* enumerations from \"@filename@\" */" \
--fprod "\n#include \"@filename@\"" \
@@ -86,6 +87,9 @@ ephy-bookmarks-type-builtins.h: stamp-ephy-bookmarks-type-builtins.h Makefile
@true
stamp-ephy-bookmarks-type-builtins.h: Makefile $(INST_H_FILES) $(NOINST_H_FILES)
$(GLIB_MKENUMS) \
+ --fhead "#if !defined (__EPHY_EPIPHANY_H_INSIDE__) && !defined (EPIPHANY_COMPILATION)\n" \
+ --fhead "#error Only <epiphany/epiphany.h> can be included directly.\n" \
+ --fhead "#endif\n\n" \
--fhead "#ifndef EPHY_BOOKMARKS_TYPE_BUILTINS_H\n" \
--fhead "#define EPHY_BOOKMARKS_TYPE_BUILTINS_H 1\n\n" \
--fhead "#include <glib-object.h>\n\n" \