aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1d6f3c65d..d865eec3d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -106,6 +106,10 @@ libephymain_la_CFLAGS = \
$(EPIPHANY_DEPENDENCY_CFLAGS) \
$(AM_CFLAGS)
+if ENABLE_DBUS
+libephymain_la_CFLAGS += $(DBUS_CFLAGS)
+endif
+
epiphany_SOURCES = ephy-main.c
epiphany_CPPFLAGS = \
@@ -135,6 +139,10 @@ epiphany_LDADD = \
$(EPIPHANY_DEPENDENCY_LIBS) \
$(INTLLIBS)
+if ENABLE_DBUS
+epiphany_LDADD += $(DBUS_LIBS)
+endif
+
BUILT_SOURCES = \
$(CORBA_SOURCE) \
$(TYPES_SOURCE)