aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/sample/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/sample/Makefile.am')
-rw-r--r--plugins/sample/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/plugins/sample/Makefile.am b/plugins/sample/Makefile.am
new file mode 100644
index 000000000..61f621445
--- /dev/null
+++ b/plugins/sample/Makefile.am
@@ -0,0 +1,20 @@
+plugindir = $(libdir)/epiphany/plugins
+
+INCLUDES = \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/src/bookmarks \
+ -I$(top_srcdir)/lib \
+ -I$(top_srcdir)/lib/egg \
+ -I$(top_srcdir)/embed \
+ $(EPIPHANY_DEPENDENCY_CFLAGS) \
+ -DSHARE_DIR=\"$(pkgdatadir)\" \
+ -DG_DISABLE_DEPRECATED \
+ -DGDK_DISABLE_DEPRECATED \
+ -DGTK_DISABLE_DEPRECATED \
+ -DGDK_PIXBUF_DISABLE_DEPRECATED \
+ -DGNOME_DISABLE_DEPRECATED
+
+plugin_LTLIBRARIES = libephy.la
+
+libephy_la_SOURCES = \
+ sample.c