aboutsummaryrefslogtreecommitdiffstats
path: root/embed/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'embed/Makefile.am')
-rw-r--r--embed/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/embed/Makefile.am b/embed/Makefile.am
index b472219bf..1640334d8 100644
--- a/embed/Makefile.am
+++ b/embed/Makefile.am
@@ -107,6 +107,7 @@ ephy-embed-type-builtins.c: stamp-ephy-embed-type-builtins.c Makefile
@true
stamp-ephy-embed-type-builtins.c: Makefile $(INST_H_FILES)
$(GLIB_MKENUMS) \
+ --fhead "#include <config.h>\n\n" \
--fhead "#include \"ephy-embed-type-builtins.h\"\n\n" \
--fprod "\n/* enumerations from \"@filename@\" */" \
--fprod "\n#include \"@filename@\"" \
@@ -127,6 +128,9 @@ ephy-embed-type-builtins.h: stamp-ephy-embed-type-builtins.h Makefile
@true
stamp-ephy-embed-type-builtins.h: Makefile $(INST_H_FILES)
$(GLIB_MKENUMS) \
+ --fhead "#if !defined (__EPHY_EPIPHANY_H_INSIDE__) && !defined (EPIPHANY_COMPILATION)\n" \
+ --fhead "#error Only <epiphany/epiphany.h> can be included directly.\n" \
+ --fhead "#endif\n\n" \
--fhead "#ifndef EPHY_EMBED_TYPE_BUILTINS_H\n" \
--fhead "#define EPHY_EMBED_TYPE_BUILTINS_H 1\n\n" \
--fhead "#include <glib-object.h>\n\n" \