aboutsummaryrefslogtreecommitdiffstats
path: root/embed/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'embed/Makefile.am')
-rw-r--r--embed/Makefile.am20
1 files changed, 2 insertions, 18 deletions
diff --git a/embed/Makefile.am b/embed/Makefile.am
index 7e93fe444..b472219bf 100644
--- a/embed/Makefile.am
+++ b/embed/Makefile.am
@@ -1,6 +1,4 @@
-SUBDIRS = $(with_engine)
-
-DIST_SUBDIRS = xulrunner mozilla webkit
+SUBDIRS = webkit
NULL =
@@ -89,23 +87,9 @@ libephyembedfactory_la_SOURCES = \
ephy-embed-factory.h
libephyembedfactory_la_CPPFLAGS = \
- -I$(top_srcdir)/embed/$(with_engine) \
+ -I$(top_srcdir)/embed/webkit \
$(AM_CPPFLAGS)
-if WITH_XULRUNNER_ENGINE
-libephyembedfactory_la_CPPFLAGS += \
- -I$(srcdir)/xulrunner/src \
- -I$(srcdir)/xulrunner/embed \
- -I$(top_builddir)/embed/xulrunner/src \
- -I$(top_builddir)/embed/xulrunner/embed \
- $(LIBXUL_INCLUDES) \
- $(NULL)
-endif
-
-if WITH_GECKO_ENGINE
-libephyembedfactory_la_CPPFLAGS += -I$(GECKO_INCLUDE_ROOT)/gtkembedmoz
-endif
-
libephyembedfactory_la_CFLAGS = \
$(GECKO_CFLAGS) \
$(DEPENDENCIES_CFLAGS) \