aboutsummaryrefslogtreecommitdiffstats
path: root/embed/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'embed/Makefile.am')
-rw-r--r--embed/Makefile.am57
1 files changed, 57 insertions, 0 deletions
diff --git a/embed/Makefile.am b/embed/Makefile.am
new file mode 100644
index 000000000..a6f43fb46
--- /dev/null
+++ b/embed/Makefile.am
@@ -0,0 +1,57 @@
+SUBDIRS = mozilla
+
+INCLUDES = \
+ -I$(top_srcdir)/embed/mozilla \
+ -I$(top_srcdir)/lib \
+ -I$(top_srcdir)/lib/widgets \
+ -I$(MOZILLA_INCLUDE_ROOT)/gtkembedmoz \
+ $(WARN_CFLAGS) \
+ $(EPIPHANY_DEPENDENCY_CFLAGS) \
+ -DSHARE_DIR=\"$(pkgdatadir)\" \
+ -DG_DISABLE_DEPRECATED \
+ -DGDK_DISABLE_DEPRECATED \
+ -DGTK_DISABLE_DEPRECATED \
+ -DGDK_PIXBUF_DISABLE_DEPRECATED \
+ -DGNOME_DISABLE_DEPRECATED
+
+noinst_LTLIBRARIES = libephyembed.la
+
+libephyembed_la_SOURCES = \
+ ephy-embed-types.h \
+ downloader-view.c \
+ downloader-view.h \
+ ephy-history.c \
+ ephy-history.h \
+ ephy-embed.c \
+ ephy-embed.h \
+ ephy-embed-shell.c \
+ ephy-embed-shell.h \
+ ephy-embed-persist.c \
+ ephy-embed-persist.h \
+ ephy-embed-popup.c \
+ ephy-embed-popup.h \
+ ephy-embed-popup-bw.c \
+ ephy-embed-popup-bw.h \
+ ephy-embed-popup-control.c \
+ ephy-embed-popup-control.h \
+ ephy-embed-event.c \
+ ephy-embed-event.h \
+ ephy-embed-utils.c \
+ ephy-embed-utils.h \
+ ephy-embed-dialog.c \
+ ephy-embed-dialog.h \
+ find-dialog.c \
+ find-dialog.h \
+ print-dialog.c \
+ print-dialog.h \
+ ephy-embed-prefs.h \
+ ephy-favicon-cache.c \
+ ephy-favicon-cache.h \
+ ephy-embed-favicon.c \
+ ephy-embed-favicon.h \
+ ephy-favicon.c \
+ ephy-favicon.h
+
+
+libephyembed_la_LIBADD = \
+ $(top_builddir)/embed/mozilla/libephymozillaembed.la